Opened 8 years ago

Closed 8 years ago

#5298 closed Bug (fixed)

Transmission not holding queue order 14017, OSX 10.8.2

Reported by: mw3demo Owned by: jordan
Priority: Normal Milestone: 2.83
Component: libtransmission Version: 2.76
Severity: Normal Keywords: backport-2.8x
Cc: hgabreu@…

Description (last modified by jordan)

This appears to happen if the magnet link hasn't downloaded the .torrent file yet, or the queue order isn't refreshed quickly enough in code, I am not sure.

I dragged from the top, two torrents below 4 magnet links, yet the torrent files started first. (All added via magnet links)

Attachments (1)

queue-order-fix.diff (599 bytes) - added by gabrielrcp 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by jordan

  • Description modified (diff)
  • Summary changed from Transmission not holding que order 14017, OSX 10.8.2 to Transmission not holding queue order 14017, OSX 10.8.2

comment:2 Changed 8 years ago by mw3demo

Just to add to the above. I had roughly 15 torrents already in Transmission added via magnet. Two had downloaded .torrent files and all were paused. First five were already completed downloads. I then added roughly 20 magnet links, in rapid succession. Transmission appears to start the most recently added links vs the queue order. I.e. It appears as if the queue is acting in a LIFO manner.

Once my client completes the current downloads, I'll try to nail this down with more specific details, over the next day or two.

comment:3 Changed 8 years ago by livings124

Is this the same as #4540?

comment:4 Changed 8 years ago by stinkfoot

I've just started experiencing this problem in 2.80 / OS X 10.7.5. It never happened for me in any previous version, so a regression may have snuck in between 2.77 and 2.80.

I've tried changing the view order, pausing and resuming all torrents, closing and re-opening Transmission, all to no avail. As per mw3demo's comment above, the queue seems to be working in LIFO order, rather than manual queue order.

comment:5 Changed 8 years ago by gabrielrcp

I believe this was introduced in r13709 (related to ticket #5199).

If I understand the changes made correctly, the new function tr_sessionGetNextQueuedTorrents gets the higher positioned torrents to be started, instead of the first in the queue. I believe that the function compareTorrentAndPositions should be inverted.

comment:6 Changed 8 years ago by livings124

#4540 was closed as a duplicate of this

comment:7 Changed 8 years ago by hgabreu

  • Cc hgabreu@… added

Changed 8 years ago by gabrielrcp

comment:8 Changed 8 years ago by jordan

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 2.83
  • Owner set to jordan
  • Status changed from new to assigned

gabrielrcp, thanks for tracking this down and for the patch!

comment:9 Changed 8 years ago by gabrielrcp

I have been running the attached (in moderation) patch on top of the 2.82 code on a linux machine for some days now. The bug is gone for me and I have not noticed any related problems.

comment:10 Changed 8 years ago by jordan

  • Keywords backport-2.8x added
  • Resolution set to fixed
  • Status changed from assigned to closed

Patch added in r14162

Note: See TracTickets for help on using tickets.