Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#530 closed Bug (fixed)

Port mapping broken in 0.95 on Leopard!!!

Reported by: starburst Owned by:
Priority: High Milestone: 1.00
Component: Transmission Version: 0.95
Severity: Major Keywords: portmapping NAT-PMP UPnP
Cc: starburst

Description

Even though the changelog said port mapping was fixed for Leopard in 0.95 it now doesn't work at all for me!!

I now see always " Port is Closed" and "Error mapping port" in the Advanced preferences. See attached screenshot.

I had no problems before with 0.94.

Attachments (2)

Picture 1.png (55.3 KB) - added by starburst 14 years ago.
Picture 1.2.png (55.3 KB) - added by starburst 14 years ago.

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by starburst

Changed 14 years ago by starburst

comment:1 Changed 14 years ago by starburst

I just reverted back to 0.94 and it works fine!

(Sorry uploaded that screenshot twice by accident)

comment:2 Changed 14 years ago by charles

What router do you have?

comment:3 Changed 14 years ago by starburst

I have an Apple Airport Extrem with 802.11n (firmware 7.2.1) which is capable of NAT-PMP if I am not mistaken. And then an ADSL router from Belkin - F1PI241EGau (firmware version 0.41) which is capable of UPnP and that is enabled.

comment:4 follow-ups: Changed 14 years ago by livings124

Does it work in a nightly build?

comment:5 in reply to: ↑ 4 Changed 14 years ago by bucho

Replying to livings124:

Does it work in a nightly build?

Nightly build has corrected the problem for me (but not the shutdown issue Ticket #531).

comment:6 in reply to: ↑ 4 Changed 14 years ago by starburst

Replying to livings124:

Does it work in a nightly build?

I downloaded r4103 from http://transmission.xpjets.com and that works fine. It says Port Open in the preferences and started to down/upload straight away.

So that seems fixed!

comment:7 Changed 14 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.00
Note: See TracTickets for help on using tickets.