Opened 8 years ago

Closed 8 years ago

#5308 closed Enhancement (invalid)

Alternative Ratio calculation

Reported by: vandome Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.77
Severity: Normal Keywords:
Cc:

Description

Dear all,

Bugs have been reported about the way ratio is calculated: https://trac.transmissionbt.com/ticket/783 https://trac.transmissionbt.com/ticket/1053 https://trac.transmissionbt.com/ticket/2087

The last one being the most serious: An impossibly high ratio leads to transmission crashes. That ticket was closed because nobody else reported the same problem, but I've had the same problem too.

From the other 2 tickets I came to understand that calculating the ratio as uploaded data/downloaded data is preferable for most users. A ratio calculated as uploaded data/possessed data/ would be more meaningful to some users. e.g. I own a seedbox and often have crazy ratios because when I resubmit a torrent, I often miss a tiny file (such as a screenshot or a description text file). Occasionally, I have to delete and re-add a torrent to avoid crashes.

Here's what I propose: Give the option to the user to calculate the ratio as he/she wishes. A simple option in the preferences would suffice. There, end of problem! Isn't it?

Change History (1)

comment:1 Changed 8 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

About the crash you mentioned: If you have a backtrace of Transmission crashing due to a ratio calculation, please report the bug and attach a backtrace with it. Crashes should always be fixed.

About the preferences option suggestion: In this particular case, the tickets you linked to are all four or five years old. Is this something that a lot of people are experiencing? It doesn't look like it. And would the people who experience think to themselves, "I bet the solution to this is in the preferences dialog"? Probably not.

Thank you for the suggestion though. And if you're able to reproduce the crash you mentioned, please do open a ticket with a crash report or backtrace. Thanks!

Note: See TracTickets for help on using tickets.