Opened 9 years ago

Closed 9 years ago

#5321 closed Bug (invalid)

noticed with trx 2.75 - reading wrong config.

Reported by: Astara Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.75
Severity: Normal Keywords: wrong-user
Cc:

Description

I seem to have noticed a problem -- not sure when it showed up but first noticed it in 2.75.

I run transmission-daemon under it's own user with a --config-dir line. But I get:

[23:59:36.939] Couldn't read "/home/law/.config/user-dirs.dirs": Permission denied

When I start or restart it with: sudo /etc/rc.d/transmission restart

(it's pretty much the same start script I submitted here a few years back.. it eventually runs transmission as:

/usr/bin/transmission-daemon --config-dir /home/transmission --dht --encryption-tolerated -f --incomplete-dir /home/transmission/data/Downloading/transmission --lpd --logfile /var/log/transmission/daemon.log --log-error --pid-file /var/run/transmissiontransmission-daemon.pid --no-portmap --allowed 192.168.4.*,192.168.3.*,127.0.0.1 --no-global-seedratio --no-watch-dir

That is invoked with startproc: where tmd_user and tmd_group are both 'torrent'

tmd_output_log=/var/log/transmission/output.log

-l $tmd_output_log -p $tmd_pidfile -u $tmd_user -g $tmd_group -n $tmd_nice

So why is the daemon, trying to access my home directory (which it doesn't have access to) when it has it's own session?

It seems to be not using the userid it is running under and seems to be ignoring the fact that a config-dir was set.

The passwd file has: torrent:x:260:260::/home/transmission:/bin/bash

But it's possible when start as a daemon, that HOME isn't set or if started via 'sudo', that it might be using my HOME directory.

Either way, it was explicitly given a config-dir, so should it even be routing around in my homedir?

Change History (2)

comment:1 Changed 9 years ago by rb07

Your report is invalid.

Main point: the configuration directory actually being used is the one you specify in the parameters, nothing else. Just look at the log carefully, you'll see that the settings, resume, and stats files are in the configuration directory.

Second point: the user-dirs.dirs file is something Transmission (in general) does, it doesn't exitst in any of my installations, but I guess it has something to do with Linux desktops... its all in libtransmission/platform.c, it looks for some "defaults" like download dir. For the daemon, and any environment that doesn't use the Open Desktop Free Desktop standard, its a waste of time.

Bottom line: its not a bug, its a feature.

Last edited 9 years ago by rb07 (previous) (diff)

comment:2 Changed 9 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.