Opened 9 years ago

Closed 9 years ago

#5323 closed Bug (duplicate)

Can't build from SVN on Debian (squeeze & wheezy)

Reported by: philippe Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.77+
Severity: Normal Keywords:
Cc:

Description

I get "No rule to make target `.deps/dht.Po'. Stop."

.deps/dht.Po is included from the Makefile, but I don't know enough about autotools to understand why this is the case.

As far as I can tell, all dependencies are installed: automake autoconf libtool intltool gettext libcurl pkg-config libssl binutils

Autogen ran without warnings. Configure shows nothing unusual. It was run with: ./configure --disable-mac --without-gtk --prefix=/opt/transmission --disable-nls

Full make log:

Making all in extras
make[1]: Entering directory `/home/philippe/Code/transmission/build/extras'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/philippe/Code/transmission/build/extras'
Making all in third-party
make[1]: Entering directory `/home/philippe/Code/transmission/build/third-party'
Making all in dht
make[2]: Entering directory `/home/philippe/Code/transmission/build/third-party/dht'
Makefile:348: .deps/dht.Po: No such file or directory
make[2]: *** No rule to make target `.deps/dht.Po'.  Stop.
make[2]: Leaving directory `/home/philippe/Code/transmission/build/third-party/dht'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/philippe/Code/transmission/build/third-party'
make: *** [all-recursive] Error 1

Change History (2)

comment:1 Changed 9 years ago by MechMK1

Are you using the 2.77 tarball or svn?

comment:2 Changed 9 years ago by philippe

  • Resolution set to duplicate
  • Status changed from new to closed

Building from SVN, cli + daemon only. It builds fine with the 2.77 tarball. I noticed an error when I ran configure.

configure: creating ./config.status
config.status: creating Makefile
config.status: creating transmission-gtk.spec
config.status: creating cli/Makefile
config.status: creating daemon/Makefile
<<SNIP>>
config.status: creating web/javascript/Makefile
config.status: creating web/javascript/jquery/Makefile
config.status: error: cannot find input file: `po/Makefile.in.in'

The file po/Makefile.in.in is supposed to be generated by intltoolize, which should get called in autogen.sh. It doesn't however, as the script fails to find glib-gettextize. According to #1885, regular gettextize isn't sufficent to build from SVN.

Installing the debian package libglib2.0-dev fixes this issue.

So this is a duplicate of #1885.

Note: See TracTickets for help on using tickets.