Opened 9 years ago

Last modified 7 years ago

#5329 reopened Bug

iOS web app gets no icon if web interface requires authentication

Reported by: dipnlik Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.77
Severity: Normal Keywords: iphone ios icon apple-touch-icon authentication
Cc:

Description

Steps to reproduce:

  • On the desktop (Mountain Lion here):
    • Open Transmission, then Preferences..., Remote tab;
    • Check Enable remote access, then check Require authentication. Fill in the username and password fields.
  • On an iOS device (iOS 6 here):
    • Open Settings, then Safari, then Clear Cookies and Data and Clear Cookies and Data again. This is to make sure the icon is not on the browser's cache;
    • Open Safari then access the aforementioned Web interface;
    • Tap the Share button.

Expected behavior:

  • Transmission's icon should show in the Add to Home Screen.

Observed behavior:

  • Transmission's icon is not shown. A screenshot from the page is shown instead.

Other notes:

  • If you tap Cancel on the device, then disable authentication on the desktop, then tap Share on the device again, the icon is shown as expected. But if you enable authentication again, then the icon is shown correctly too, probably from the browser's cache.
  • Not sure if this is a bug in Transmission or in MobileSafari.

Change History (5)

comment:1 Changed 9 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

I don't believe this to be a bug in the web ui, since webclip-icon.png is set as the apple-touch-icon at the top of index.html. This is likely a bug in MobileSafari?. Please reopen if this is wrong.

comment:2 Changed 9 years ago by dipnlik

apple-touch-icon is setup correctly, and it works without authentication just fine.

I'm not sure how the authentication system works internally but it probably is preventing MobileSafari to reach the image. Can the authentication system be modified to whitelist the icon? Even if there's a bug in Safari—that it doesn't use the previously authenticated session in the Share menu or something like that—, whitelisting the icon could be a workaround that wouldn't reduce web ui's overall security (I think).

Does that make sense?

comment:3 Changed 9 years ago by livings124

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:4 Changed 8 years ago by lazybones

Along the same lines if you do bookmark the webUI with authentication enabled... You can't reconnect without task switching and killing the previous session, as it will attempt to resume and declare that there is no connection.

I think this is actually a bug with authentication that changed some time ago.. It is highly repeatable on an iPhone that is for sure.

comment:5 Changed 7 years ago by tripkip

I experience the same issue. It would be great to see this resolved. Would like to see a nice icon on my home screen for transmission.

Note: See TracTickets for help on using tickets.