Opened 8 years ago

Closed 8 years ago

#5340 closed Bug (fixed)

Segfault when opening "Preferences", GTK+ 3.8.0

Reported by: rustam Owned by: jordan
Priority: Normal Milestone: 2.80
Component: GTK+ Client Version: 2.77+
Severity: Normal Keywords:
Cc:

Description

OS: Arch Linux with gtk3 3.8.0-1(gnome-unstable) Transmission: SVN r14057 (affects 2.77 as well)

Description:

Transmission segfaults when selecting "Edit" -> "Preferences" Error message:

(transmission-gtk:7591): GLib-GObject-CRITICAL **:
 g_object_get_qdata: assertion `G_IS_OBJECT (object)' failed
Segmentation fault (core dumped)

The problem is caused due to the "selection-changed" callback for new_path_chooser_button in tr-prefs.c being invoked too early(initiated by the gtk_file_chooser_set_filename() call). I'm not sure whether this is a regression in GTK+ 3.8 or expected behavior. Moving g_signal_connect() below gtk_file_chooser_set_filename() appears to fix the problem.

Attachments (1)

prefs_segfault_r14057.patch (653 bytes) - added by rustam 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by rustam

comment:1 Changed 8 years ago by jordan

  • Milestone changed from None Set to 2.80
  • Status changed from new to assigned

Thanks for the patch. Applied in r14059

comment:2 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.