Opened 8 years ago

Closed 4 years ago

#5348 closed Bug (fixed)

Misidentification of local session

Reported by: rb07 Owned by: mike.dld
Priority: Normal Milestone: 3.00
Component: Qt Client Version: 2.77
Severity: Normal Keywords: ssh tunnel
Cc:

Description

From a bug report on the Windows port (which doesn't affect the original app): https://sourceforge.net/p/trqtw/bugs/28/#41d6 :

The use case is Transmission-Qt connected to a remote session through a ssh tunnel (more detail at the above link).

The problem is that the session::isLocal() returns true, due to the IP address or localhost name used. This causes problems in the following places:

On the main window:

  1. The menu option "Open Folder" will be enabled. <-- possible crash?

On the (Open Torrent) Options panel:

  1. Set download location will be a button, which opens the local file browser, instead of a text field.
  2. Hides one of the columns on the table.
  3. Enables the verify button. <-- possible crash if used?

To solve the original bug I changed from using isLocal() to isServer(), this of course stops the intended use of isLocal(), which enables local operations even if the application is just a front end for the daemon or another Transmission client.

Change History (3)

comment:1 Changed 4 years ago by mike.dld

  • Owner changed from jordan to mike.dld
  • Status changed from new to assigned

comment:3 Changed 4 years ago by mike.dld

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.