Opened 9 years ago

Closed 9 years ago

#5364 closed Bug (duplicate)

Open Folder button behavior for single file torrents.

Reported by: stephenmw Owned by: jordan
Priority: Normal Milestone: None Set
Component: Qt Client Version: 2.77
Severity: Normal Keywords:
Cc:

Description

Conditions:

Using: transmission-qt 2.77 from Debian Experimental Downloading a torrent containing a single mp3 file within a folder.

What happens:

If you right click on the torrent while it is downloading and select "Open Folder", nothing happens. When the torrent has finished downloading and you select the same button, it starts a media player.

What I expect to happen:

"Open Folder" should never open a file. I think adding a separate open file button for single file torrents is not a bad idea. The Open Folder button should do the following:

If torrent is multi-file, the file manager should be opened to the top level folder (same as is currently done).

If a torrent is single-file but that file is in a folder, the file manager should be opened to the top level folder. "x/y/z.mp3" should open to folder "x".

If a torrent does not contain a folder (z.mp3), then the filemanager should be opened to the folder containing z.mp3 and z.mp3 should be selected. If the torrent hasn't finished downloading, z.mp3.part should be selected. For an example, see chrome's "show in folder" button for downloads.

This will make Open Folder's behavior more consistent and predictable.

Change History (4)

comment:1 Changed 9 years ago by rb07

Duplicate of #5195 (and 2 previous reports), which itself is a duplicate of #4824, and was supposed to fix exactly what you describe.

comment:2 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 9 years ago by stephenmw

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, what ticket is this a duplicate of? The problem has been brought up before. However, all tickets related to it have been closed and the problem persists.

comment:4 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from reopened to closed

#5195 has been closed as fix for the next release...

Note: See TracTickets for help on using tickets.