Opened 9 years ago

Closed 9 years ago

#5368 closed Enhancement (duplicate)

Enhancement: [transmission-remote] ability to get peer (IP) geolocation

Reported by: tals Owned by: jordan
Priority: Normal Milestone: None Set
Component: Utils Version: 2.77
Severity: Normal Keywords:
Cc:

Description

It would be nice to have an ability in transmission-remote to get peer country information by IP using a free web service (freegeoip.net or similar) e.g.: transmission-remote -t 1 –geo: 74.125.235.2 - United States, CA

-geo would be an optional parameter e.g: http://freegeoip.net/json/74.125.235.2?callback=func RESPONSE: func({"ip":"74.125.235.2","country_code":"US","country_name":"United States","region_code":"CA","region_name":"California","city":"Mountain View","zipcode":"94043","latitude":37.4192,"longitude":-122.0574,"metro_code":"807","areacode":"65

or in XML,CSV format: http://freegeoip.net/xml/74.125.235.2?callback=func http://freegeoip.net/csv/74.125.235.2?callback=func

P.S. There was a similar ticket: https://trac.transmissionbt.com/ticket/2216

Change History (1)

comment:1 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

As you said, this is a duplicate of #2216

Note: See TracTickets for help on using tickets.