Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5377 closed Bug (fixed)

Selecting directories in preferences doesn't work

Reported by: nagisa Owned by: jordan
Priority: Normal Milestone: 2.80
Component: GTK+ Client Version: 2.77
Severity: Critical Keywords: directories, preferences
Cc: simonas+trac.transmissionbt.com@…

Description

Backstory: Here I was wondering why does a directory with name en_GB.utf8 is appearing in my home directory on every boot. Apparently it was created by transmission-gtk.

How to reproduce:

  1. (Probably needed) Go to preferences window, set “Save to Location” to some directory deeper in home (~/downloads/something/ maybe?).
  2. Close preferences window.
  3. Reopen preferences window – observe some other directory or (None) is selected instead of chosen directory.

How to reproduce II:

  1. Turn off transmission client.
  2. Open $XDG_CONFIG_HOME/transmission/settings.json with your favourite editor.
  3. Set value of “download-dir” to value of your liking (~/downloads/something/ maybe?).
  4. Open transmission. Observe that both value in settings.json is changed, nor it is used for current transmission session.

How to reproduce III:

  1. Do everything in “How to reproduce” (except third point).
  2. Restart transmission client
  3. Observe some strange value in “Save to Location”.

Opening torrents does save to my preferred location regardless of value in “Save to Location”.

Summary: I couldn't set my preferred location for torrents for option “Save to Location”, but it seems to be not used as torrents are saved to my preferred location anyway.

Attachments (1)

Screenshot from 2013-06-07 23:13:22.png (6.2 KB) - added by nagisa 8 years ago.
The screenshot.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by nagisa

The screenshot.

comment:1 Changed 8 years ago by nagisa

  • Cc simonas+trac.transmissionbt.com@… added
  • Severity changed from Normal to Critical

Since I reported this issue things are getting more and more out of my hands. Transmission now have became totally unreliable while liberally sprinkling directories all around my home as well. I think attached screenshot illustrates the issue well.

comment:2 Changed 8 years ago by jordan

After changing the download directory in the Preferences Dialog, but before exiting Transmission, please grep for download-dir in ~/.config/transmission/settings.json. Did the download-dir value get changed correctly?

What do you get when grepping for XDG_DOWNLOAD_DIR in ~/.config/user-dirs.dirs?

comment:3 Changed 8 years ago by nagisa

𝛌cat $XDG_CONFIG_HOME/user-dirs.dirs | grep DOWNLOAD
XDG_DOWNLOAD_DIR="$HOME/downloads"
𝛌echo $HOME
/home/nagisa

So. In case of running transmission session. Current download-dir value set manually in config file.

  1. Grep to check if everything ok "download-dir": "/home/nagisa/downloads",
  2. Open preferences dialog "download-dir": "/home/nagisa/en_GB.utf8",
  3. Set download location through preferences dialog "download-dir": "/home/nagisa/downloads",
  4. Turn off preferences dialog "download-dir": "/home/nagisa/downloads",
  5. Turn off transmission "download-dir": "/home/nagisa/downloads",
  6. Start transmission "download-dir": "/home/nagisa/downloads",
  7. Open preferences dialog "download-dir": "/home/nagisa/home/nagisa",

So exact culprit seems to be opening preferences dialog here. I have tried removing preferences directory and starting cleanly – same behaviour persists.

comment:4 Changed 8 years ago by jordan

Are you able to build from svn or a nightly tarball at https://build.transmissionbt.com/job/trunk-linux/ ?

There have been several changes since 2.77, but in particular I'm wondering if https://trac.transmissionbt.com/changeset/14059/trunk/gtk/tr-prefs.c has any effect on the issue you're seeing.

comment:6 Changed 8 years ago by jordan

  • Milestone changed from None Set to 2.80
  • Resolution set to fixed
  • Status changed from new to closed

Glad to hear it :)

comment:7 Changed 8 years ago by Forage

Would it be possible to create a nightly build in the Transmission PPA for Raring so I can test if this, as well as issue #5370, has been resolved?

Note: See TracTickets for help on using tickets.