Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5387 closed Bug (wontfix)

Smaller OS X PNG files

Reported by: Mangix Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.77
Severity: Normal Keywords:
Cc:

Description

As promised, https://dl.dropboxusercontent.com/u/102011983/transmission-macosx-pngs.tar.gz

I thought I had posted these a while back but I guess not. 95 icons this time.

Change History (11)

comment:1 Changed 8 years ago by livings124

There are issues with the images you sent ending in template. The images need to be black and transparent - no other colors. This appears to be causing an issue with #5390.

comment:2 Changed 8 years ago by Mangix

These new ones or old ones I made some time ago? If these, I'll take a look.

comment:3 Changed 8 years ago by livings124

Both have the issue it seems.

comment:4 Changed 8 years ago by Mangix

It seems that something went wrong the last time I compressed the images. The old ones are smaller than they should be. I wonder why this is...

I guess this means that my previous commit with the os x icons should be reverted.

Try testing these and see if the issue pops up: https://dl.dropboxusercontent.com/u/102011983/transmission-test.zip

comment:5 Changed 8 years ago by livings124

The images ending in "template", which need to only have black and transparent areas, are the ones that aren't working.

comment:6 Changed 8 years ago by livings124

Mangix: ping

comment:7 Changed 8 years ago by Mangix

Sorry, been busy these past few days.

The more I look at this, the more confused I am. Initially I was thinking that the problems were due to the so called "dirty alpha channel" cleaning that I did. But the problem is that I did not even touch the alpha last time around and these problems are present in both versions of the icons (according to you).

The other issue is that these icons display perfectly fine for me in a web browser and in explorer. I have not used the mac version of transmission and am unable to see why there is a problem.

The only thing I can think of is that the PNG decoder used by transmission on OS X is buggy and does not properly decode images that can be decoded by everything else that I've tried. Weird since according to the pngcheck utility included with libpng, all of these images are fine.

If the previous images work fine, then might as well revert to them.

comment:8 follow-up: Changed 8 years ago by livings124

From the documentation: "Images you mark as template images should consist of only black and clear colors. You can use the alpha channel in the image to adjust the opacity of black content, however."

Do the images deviate from that at all?

comment:9 in reply to: ↑ 8 Changed 8 years ago by Mangix

Replying to livings124:

From the documentation: "Images you mark as template images should consist of only black and clear colors. You can use the alpha channel in the image to adjust the opacity of black content, however."

Do the images deviate from that at all?

no. The images are grayscale with an alpha channel.

comment:10 Changed 8 years ago by livings124

That's strange. I've filed a bug report with Apple, and hopefully we'll get a response. Otherwise I'll have to revert the images.

comment:11 Changed 8 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

I'm going to revert the images and resolve this. I'm not sure why it's broken, but a slightly larger size is worth fixing #5390

Last edited 8 years ago by livings124 (previous) (diff)
Note: See TracTickets for help on using tickets.