Opened 9 years ago

Closed 7 years ago

#5392 closed Bug (worksforme)

regression in 2.80's GTK+ torrent file list view: file priority toggle is obscured off the right-hand side of the window

Reported by: jordan Owned by: jordan
Priority: Normal Milestone: Sometime
Component: GTK+ Client Version: 2.80
Severity: Normal Keywords:
Cc:

Description

Summary says it all. In 2.7x, you could pop up the file list and toggle the individual file's download priorities without having to scroll; now the priorities aren't visible by default and you have to resize the dialog or scroll right to see them.

Change History (6)

comment:1 Changed 9 years ago by jordan

  • Milestone changed from None Set to 2.81

comment:2 Changed 9 years ago by jordan

  • Milestone changed from 2.81 to Sometime

comment:3 Changed 7 years ago by mike.dld

Closed #5815 and #5565 and duplicates of this ticket.

comment:4 Changed 7 years ago by mike.dld

Setting max-width-chars cell renderer property to 1 kind of fixes it:

  • gtk/file-list.c

     
    941941  gtk_tree_view_column_add_attribute (col, rend, "pixbuf", FC_ICON);
    942942  /* add text renderer */
    943943  rend = gtk_cell_renderer_text_new ();
    944   g_object_set (rend, "editable", TRUE, NULL);
    945   g_object_set (rend, "ellipsize", PANGO_ELLIPSIZE_END, "font-desc", pango_font_description, NULL);
     944  g_object_set (rend, "editable", TRUE,
     945                      "ellipsize", PANGO_ELLIPSIZE_END,
     946                      "max-width-chars", 1,
     947                      "font-desc", pango_font_description, NULL);
    946948  g_signal_connect (rend, "edited", (GCallback)cell_edited_callback, data);
    947949  gtk_tree_view_column_pack_start (col, rend, TRUE);
    948950  gtk_tree_view_column_set_attributes (col, rend, "text", FC_LABEL, NULL);

P.S. I'm not seeing horizontal scroll bar (even w/o the "fix") for files tree view with GTK+ 3.12.2 regardless of dialog width and column widths (taking into account policy is set to automatic), which is weird.

Last edited 7 years ago by mike.dld (previous) (diff)

comment:5 Changed 7 years ago by mike.dld

Updated to GTK+ 3.14.9 today. The issue seems to be fixed w/o any changes on Transmission side, although the behavior now looks exactly the same as the one with the patch above: double-clicking on right border of name column header adjusts column width so that only file icon is visible instead of making it wider so that complete name is visible. What an odd fix...

comment:6 Changed 7 years ago by mike.dld

  • Resolution set to worksforme
  • Status changed from new to closed

I'm going to close this since the defect is (or rather was) most certainly in GTK+ itself. Building with recent versions of the library doesn't exhibit the described behavior.

Note: See TracTickets for help on using tickets.