Opened 9 years ago

Closed 9 years ago

#5393 closed Bug (incomplete)

can't find seeds or peers

Reported by: Bugmenot Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.80
Severity: Normal Keywords:
Cc:

Description

i'm using latest transmission daemon and recently started having problem about once a day. it gets "stuck" and can't find any seeds or peers. i add torrents from different trackers and they all have the problem. stopping and restarting torrent doesn't fix problem. deleting torrent and re-adding doesn't fix it either. the only thing that works is to kill transmission and restart it. then all the torrents find seeds and peers. so it's not a tracker problem, cause it affects torrents from different trackers.

Change History (10)

comment:1 Changed 9 years ago by tals

Seems to the problem with the statuses: still IDLE while seeding...

$ transmission-remote -V
transmission-remote 2.80 (14103)

$ transmission-remote -l
ID     Done       Have  ETA           Up    Down  Ratio  Status       Name
   1   100%    8.22 GB  Done        13.0     0.0   36.9  Idle         MY_FILES

comment:2 Changed 9 years ago by Bugmenot

Maybe that's related, but it's not the problem I'm experiencing. When adding torrents transmission could find any seeds or peers so couldn't even download any data. It wasn't a display issue, because I was checking the debug log, bandwidth, and the torrent data download directory for activity.

comment:3 Changed 9 years ago by x190

  • Component changed from Transmission to libtransmission
  • Owner set to jordan

comment:4 Changed 9 years ago by rolux

I'm experiencing the exact same behaviour (newly added torrents remain w/o peers until relaunch) with the Mac client. This used to work in 2.77.

comment:5 Changed 9 years ago by x190

peer-msgs.c (r14083):

static void
updateInterest (tr_peerMsgs * msgs UNUSED)
{
    /* FIXME -- might need to poke the mgr on startup */
}

*poking the mgr* :-)

comment:6 follow-up: Changed 9 years ago by x190

bugmenot and rolux: Are you able to connect to trackers when this issue occurs? Are those trackers providing peers? If you cannot connect to trackers, are you then able to connect upon re-launch? Please try to provide a legal torrent that exhibits this behavior for testing purposes.

comment:7 in reply to: ↑ 6 Changed 9 years ago by Bugmenot

Replying to x190:

bugmenot and rolux: Are you able to connect to trackers when this issue occurs?

transmission can not connect to any trackers when this happens

Are those trackers providing peers? If you cannot connect to trackers, are you then able to connect upon re-launch?

yes, that was stated in my original description.

the status for existing torrents that were seeding at the time this happened didn't change, but they weren't actively seeding to any peers before that so hard to tell if these torrents were also affected. i didn't really see much in the debug log, just the new torrents being verified, then no other messages.

Please try to provide a legal torrent that exhibits this behavior for testing purposes.

the problem was not specific to any tracker or torrent, i tried both private and public trackers. and the problem is not reproducible for me in the sense that i can't trigger it by any action, it just happens randomly.

comment:8 Changed 9 years ago by jordan

Does this problem persist after r14108?

The peer manager was miscounting which peers were active and which weren't. This is directly related to the problem reported by tals in comment:1, and is /possibly/ behind the behavior described here by bugmenot and rolux.

comment:9 Changed 9 years ago by livings124

Bugmenot: can you try a nightly build? https://build.transmissionbt.com/

Last edited 9 years ago by livings124 (previous) (diff)

comment:10 Changed 9 years ago by jordan

  • Resolution set to incomplete
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.