Opened 8 years ago

Closed 8 years ago

#5396 closed Bug (fixed)

Not showing active torrents in web client and transmission-remote-gtk

Reported by: rezax Owned by:
Priority: Highest Milestone: None Set
Component: Transmission Version: 2.80
Severity: Normal Keywords:
Cc:

Description

After update transmission to 2.80, list of Active torrents is empty in both web-interface and transmission-remote-gtk, when i seeding torrents. Morning on previous version all is work. This is screenshot of this hell: http://apikabu.ru/13071/2c8

Attachments (3)

2013-07-01-202650_1600x900_scrot.png (82.2 KB) - added by rezax 8 years ago.
screenshot
transmission_webui_2.80_issues.png (19.9 KB) - added by JDirk 8 years ago.
Transmission_web_ui_issues
transmission_qt_2.80_issues.png (28.3 KB) - added by JDirk 8 years ago.
Transmission_web_QT_issues

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by rezax

screenshot

comment:1 Changed 8 years ago by jordan

I'm not able to reproduce this in 2.80's web client, and 2.80 didn't introduce any backwards-incompatible API for the remote clients... so I'm not sure what's going on here. Also, it looks like you're able to connect to the transmission session since you're seeing the web client's html show up.

  • If you change the filter to all/all, do any torrents show up? ie, are you seeing no torrents at all, or just no active ones?
  • What happens if you run transmission-remote 192.168.1.2:9091 --debug -l on the command line? Does the json output from the transmission session include any torrents in it?

Changed 8 years ago by JDirk

Transmission_web_ui_issues

Changed 8 years ago by JDirk

Transmission_web_QT_issues

comment:2 Changed 8 years ago by JDirk

I am experiencing the same sort of problem with the transmission webui and transmission-qt on 2.80. The number of active torrents are not being reported properly as you can see from the disparity between total upload bandwidth being reported and that of the individual torrents displayed.

Transmission webui - http://i.imgur.com/H6w7bky.png Transmission-qt - http://i.imgur.com/y31P0kA.png

comment:3 Changed 8 years ago by rezax

Seems looks this happens when lowercased-"u"-flagged torrents are uploading.

comment:4 Changed 8 years ago by rb07

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Not show active torrents both in web and transmission-remote-gtk to Not showing active torrents in web client and transmission-remote-gtk

This is the same problem reported in #5391, which is already fixed on the repository.

Note: See TracTickets for help on using tickets.