Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5402 closed Bug (invalid)

continuing to upload after ratio is reached, while still downloading

Reported by: Yamaki Owned by: jordan
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.73
Severity: Normal Keywords:
Cc:

Description

Using Transmission 2.73 (13592) on Ubuntu 12.04, I have noticed that one torrent (which has not yet finished downloading, currently at 99.6%) has reached a ratio of (currently) 1.94, though both the torrent specific settings, and the general/global settings, say to stop seeding at ratio 1.5.

I'm not sure if this is related to https://trac.transmissionbt.com/ticket/1848 or not, but suspect it maybe.

I'm not sure what to do next.

Change History (4)

comment:1 Changed 8 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

By design, the ratio only applied to transfers that have finished downloading.

comment:2 Changed 8 years ago by Yamaki

Thanks for confirming this. Is this documented anywhere?

Can I also ask why this decision was taken? It seems a bit, ah, odd. In my case, when I do, ever, finish downloading the torrent, I'll have uploaded well above the 1.5 times I normally upload. Which, especially for people who have uploads metered, or who are otherwise on connections with difficulties, can be a pain (e.g. in the wallet).

I think that it might be better if at any one point, the client does not upload if it would take the ratio of upload to download significantly (however defined, I would say by 5%) above the limit set.

Alternatively, if you don't want to change that design decision, could you make it a bit clearer in the UI that this is the case. E.g. in the global options instead of "seeding", change the wording to "seeding after download finished", and in the individual torrent options, have "seeding limits, after the download has finished". This would make it clearer that it is not a bug.

Thanks for your hard work!

comment:3 Changed 8 years ago by x190

Yamaki: If you are not willing to upload, you will not be able to download at all. You can, however, limit your upload rate to as little as 1 KB/s, if you wish.

comment:4 Changed 8 years ago by Yamaki

You misunderstand perhaps. I am perfectly willing to upload. I just don't want to upload more than 1.5 times what I download (unless I specifically change it for a particular torrent, or more generally)

Of course, I could be misunderstanding the torrent system. But I didn't think that it required one to be continually uploading. Especially when my general (all time) ratio is quite good.

Anyway, regardless. There is still room for misunderstanding when it comes to the wording in the options sections. I think that making it more clear that the seeding ratio only kicks in after the download has finished, would be good.

Note: See TracTickets for help on using tickets.