Opened 14 years ago

Closed 14 years ago

#541 closed Bug (fixed)

Transmission-cli Binary/Man page Name Mismatch

Reported by: ACoolie Owned by:
Priority: Lowest Milestone: 1.00
Component: CLI Version: 1.02+
Severity: Trivial Keywords:
Cc:

Description

In the latest trunk, transmission-cli is installed as a binary as transmission-cli (which is good, since it keeps the name constant with the daemon binaries), but the man page installs at transmissioncli. See cli/Makefile.am

Attachments (1)

cli-t541.diff (23.8 KB) - added by tiennou 14 years ago.
Patch fixing this. I also added the manpage to the Xcode project, so that it's easier to access (and update ;-)).

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by tiennou

Patch fixing this. I also added the manpage to the Xcode project, so that it's easier to access (and update ;-)).

comment:1 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.00
  • Resolution set to fixed
  • Status changed from new to closed

closed, fixed in r4405. cross-ref: ticket #564

comment:2 Changed 14 years ago by charles

  • Type changed from Task to Bug Report

comment:3 Changed 14 years ago by ACoolie

  • Resolution fixed deleted
  • Status changed from closed to reopened

I really disagree with the change that was made in r4405. Tiennou's patch fixed it fine. Now we have three binaries named transmission-remote, transmission-daemon, and transmission-proxy, and one named transmissioncli. This also forces an extra keypress in tab completion (instead of "trans[tab]remote" i type "trans[tab]-remote".

While I agree the man page, help message, and binary name should all match, I also believe the binary names should be consistent, and I'm reopening this.

comment:4 Changed 14 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

"transmissioncli" is consistent with the command-line client's pre-0.90 name.

Note: See TracTickets for help on using tickets.