Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5414 closed Bug (fixed)

Download speed very slow until edited

Reported by: KenDRhyD Owned by: livings124
Priority: Normal Milestone: 2.82
Component: Mac Client Version: 2.80
Severity: Major Keywords:
Cc:

Description

Ever sine upgrading to the latest build (2.80 (14103), when Transmission is first launched the download speed is very slow (3-15 KBps). If I open the preferences to the Bandwidth page and edit the download rate, then all is fine. Same issue occurs each time it is launched.

Change History (16)

comment:2 Changed 7 years ago by hunpff

Just reporting that the same occurs in 2.81 (14128)

comment:3 Changed 7 years ago by interconnect

I can confirm this on 2.80 and 2.81. I was experiencing very low download speeds (less than 1 Mb/s) on my connection, which is 30 Mb/s down. Thinking it was an ISP issue, I ran some tests at M-Lab and found no ISP throttling. After reverting back to 2.77 regular speeds resumed. I tested this with two large torrents and immediately after installing 2.77 normal speeds resumed. I would also put the priority of this bug at High, given the fact that it significantly impacts the core functionality of this app.

comment:5 Changed 7 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

livings, can you reproduce this issue on the Mac client?

comment:6 follow-up: Changed 7 years ago by x190

Can anyone experiencing this problem try removing your preference file and letting Transmission generate a new one?

~/Library/Preferences?/org.m0k.transmission.LSSharedFileList.plist ~/Library/Preferences?/org.m0k.transmission.plist (re-do Preferences after installation)

"~" = your home folder. http://osxdaily.com/2011/07/22/access-user-library-folder-in-os-x-lion/

comment:7 in reply to: ↑ 6 ; follow-up: Changed 7 years ago by anesheret

Replying to x190:

Can anyone experiencing this problem try removing your preference file and letting Transmission generate a new one?

Yes, I can confirm.

comment:8 in reply to: ↑ 7 Changed 7 years ago by x190

Replying to anesheret:

Replying to x190:

Can anyone experiencing this problem try removing your preference file and letting Transmission generate a new one?

Yes, I can confirm.

Do your speed settings now work correctly after you restart Transmission without opening or editing your preferences?

comment:9 Changed 7 years ago by anesheret

  1. remove Transmission settings ( 2 files from ~/Library/Preferences? folder )
  2. run Transmission and do not touch any settings (not opening or editing preferences)
  3. rerun Transmission by opening torrent file
  4. download speed is good!
  5. open settings set download speed limit to 3000 kbit/s
  6. download speed is ok ~ 3000 kbit/s
  7. restart Transmission
  8. download speed is to slow ~100 kbit/s
  9. open settings and make changes (even to same limit), speed is now ok ~ 3000 kbit/s

comment:10 Changed 7 years ago by fletom

I can also confirm that this exact problem occurs using 2.81 on Mac OS 10.6.8. In my opinion this bug is more than just "normal" severity, as for most users it renders Transmission close to useless as a BitTorrent? client. It took me a long, frustrating time to figure out what was going on.

comment:11 Changed 7 years ago by x190

Patch to fix:

/macosx/Controller.m

-Line 258: tr_variantDictAddInt(&settings, TR_KEY_downloadSpeed, [fDefaults integerForKey: @"DownloadLimit?"]); +Line 258: tr_variantDictAddInt(&settings, TR_KEY_speed_limit_down, [fDefaults integerForKey: @"DownloadLimit?"]);

comment:12 Changed 7 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

Thanks x190! r14153

comment:13 Changed 7 years ago by livings124

  • Milestone changed from None Set to 2.82
  • Severity changed from Normal to Major

comment:14 Changed 7 years ago by fletom

I'm not really sure how these things work, so forgive my ignorance, but would it be possible to have this released in the Sparkle beta channel so that us users can have the fix right away?

comment:15 Changed 7 years ago by Robby

As far as I know the Transmission Project doesn't do betas so if I were you I'd revert to the last working version for now.

comment:16 Changed 7 years ago by x190

Please download and test the latest build from here:

https://build.transmissionbt.com/job/trunk-mac/

Note: See TracTickets for help on using tickets.