Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#5419 closed Bug (duplicate)

Torrent queue going backwards

Reported by: pynzrz Owned by:
Priority: Highest Milestone: None Set
Component: Transmission Version: 2.80
Severity: Blocker Keywords:
Cc:

Description

It was perfectly normal yesterday. Now today, once the first torrent is done, the last torrent will start instead of the second torrent.

Change History (2)

comment:1 Changed 9 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

Marking as a duplicate of #4540.

comment:2 Changed 8 years ago by guss77

I also see the same problem with transmission-daemon 2.82, though I only experience it with seeding - it may also happen on download, but I don't have enough data.

Steps to reproduce:

  1. Set max-seed to 1, and max-seed-ratio to something.
  2. Have 3 torrents that can seed.
  3. Start them in order
  4. Wait for the first one to finish seeding.

Expected behavior: 2nd torrent start seeding.

Actual behavior: 3rd torrent start seeding.

This is not a dup of #4540, which is about the having the queue order preserved when modifying it with the web interface and restarting transmission-daemon. This bug has nothing to do with changing the queue order or restarting.

Note: See TracTickets for help on using tickets.