Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5422 closed Bug (invalid)

Speed settings are never allowed to be fully reached

Reported by: x190 Owned by: livings124
Priority: Low Milestone: None Set
Component: libtransmission Version: 2.80
Severity: Trivial Keywords:
Cc:

Description

Speed settings are never allowed to be fully reached. Requires a 3 digit speed setting.

Ex 1: Set DL speed to 100 KB/s. Max indicated will be 99.9 KB/s. Ex 2: Set DL speed to 690 KB/s. Max indicated will be 689.7 KB/s.

This is a regression sometime since r11889.

Tested using r14125 and Mac Client on SL 10.6.8.

UL settings were not tested.

Change History (5)

comment:1 Changed 9 years ago by x190

https://forum.transmissionbt.com/download/file.php

https://forum.transmissionbt.com/download/file.php

Version 0, edited 9 years ago by x190 (next)

comment:2 Changed 9 years ago by jordan

  • Component changed from libtransmission to Mac Client
  • Owner changed from jordan to livings124

r11889 was two years ago, so using this as a benchmark for regression isn't particularly helpful. Could you try out newer versions?

I'm not seeing this behavior in the GTK+ client, so I'm assigning this ticket to the Mac client.

comment:3 follow-up: Changed 9 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

These numbers are coming straight from libtransmission.

Data sent and received can't be exact - these numbers are pretty good.

comment:4 Changed 9 years ago by livings124

  • Component changed from Mac Client to libtransmission

comment:5 in reply to: ↑ 3 Changed 9 years ago by x190

Replying to livings124:

These numbers are coming straight from libtransmission.

Data sent and received can't be exact - these numbers are pretty good.

It's aesthetic garbage, IMO. There's no such issue with r11889 and jordan says he doesn't see it in GTK+ client. What are you seeing when testing with the Mac Client on 10.8/9?

Note: See TracTickets for help on using tickets.