Opened 8 years ago

Closed 8 years ago

#5458 closed Enhancement (duplicate)

ability to name torrents, regardless of the folder name

Reported by: emoxam Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.82
Severity: Normal Keywords:
Cc:

Description

Please make an ability to rename torrents. So torrents can be named regardless of destination folder.

Thank you!

Change History (16)

comment:1 Changed 8 years ago by livings124

This is the primary new feature in 2.8. If this is something different, can you be more specific?

comment:2 Changed 8 years ago by leandroong

This is how I did it: 1.) Settings.json "script-torrent-done-enabled": true, "script-torrent-done-filename": "/mnt/optware/rdata/tr_rename_and email.sh",

2.)tr_rename_and_email.sh #!/bin/sh

# TR_APP_VERSION # TR_TIME_LOCALTIME # TR_TORRENT_DIR # TR_TORRENT_HASH # TR_TORRENT_ID

TARGET_FNAME1="torrent1.avi" TARGET_FNAME2="torrent2.avi" TARGET_FNAME3="torrent3.avi" TARGET_FNAME4="torrent4.avi" TARGET_FNAME5="torrent5.avi" TARGET_FNAME6="torrent6.avi" TARGET_FNAME7="" TARGET_FNAME8="" TARGET_FNAME9="" TARGET_FNAME10=""

cd /mnt/data/downloads case $TR_TORRENT_HASH in

b7bc504f0d52107fb0874ce0d3d816487ea30123) mv "$TR_TORRENT_NAME" "$TARGET_FNAME1";

;;

b7bc504f0d52107fb0874ce0d3d816487ea30e86) mv "$TR_TORRENT_NAME" "$TARGET_FNAME2";

;;

eef844ea9ccf6496b97df0fc91d6ee948c6961f2) mv "$TR_TORRENT_NAME" "$TARGET_FNAME3";

;;

290e3df94979fb06815c99eb20b315072d3c03f7) mv "$TR_TORRENT_NAME" "$TARGET_FNAME4";

;;

1eafa221bcd1e184a715a6061ab52de00fa08392) mv "$TR_TORRENT_NAME" "$TARGET_FNAME5";

;;

a84422b07328bcec82accc8fb295cbdc09cabf9b) mv "$TR_TORRENT_NAME" "$TARGET_FNAME6";

;;

7) mv "$TR_TORRENT_NAME" "$TARGET_FNAME7";

;;

8) mv "$TR_TORRENT_NAME" "$TARGET_FNAME8";

;;

9) mv "$TR_TORRENT_NAME" "$TARGET_FNAME9";

;;

10) mv "$TR_TORRENT_NAME" "$TARGET_FNAME10";

;;

esac

transmission-remote 9091 -t$TR_TORRENT_ID --remove 2>/dev/null

cat << EOF > /tmp/tr_mail date: date -R to: leandrong_testmail@… subject: Trasnmission download completion from: leandroong_testmail@…

Transmission finished downloading "$TR_TORRENT_NAME", ID= $TR_TORRENT_ID, on $TR_TIME_LOCALTIME"

Folder Listing: =============== ls /mnt/data/downloads EOF

msmtp -t </tmp/tr_mail rm /tmp/tr_mail

Last edited 8 years ago by leandroong (previous) (diff)

comment:3 Changed 8 years ago by leandroong

It would be nice if you can automate replacement of hash value. Any suggestion on how to simplify my lousy script?

Last edited 8 years ago by leandroong (previous) (diff)

comment:4 Changed 8 years ago by emoxam

What means primary new feauture ?

comment:5 Changed 8 years ago by archa

I think this is about torrent-set-name. At now we can 'torrent-set-location' and torrent name change with the torrent path. For example, i have torrent with tv series xxx season yy. I download this torrent in folder \media\video\serials\xxx\[season yy] and we have torrent name is [season yy]. But we wish torrent name is 'xxx [season yy]'.

comment:6 Changed 8 years ago by emoxam

I can have a few VIDEO_TS torrents in my torrent list, i want ability to change their name without changing name of files, folders and whatever it can be.

comment:7 follow-up: Changed 8 years ago by livings124

What operating system are you running?

comment:8 Changed 8 years ago by leandroong

I run transmission on my tomato router, OS is linux.

comment:9 in reply to: ↑ 7 Changed 8 years ago by emoxam

Replying to livings124:

What operating system are you running?

Who did you ask ?

comment:10 Changed 8 years ago by livings124

You, emoxam. What operating system are you running?

comment:11 Changed 8 years ago by emoxam

Windows 8 Pro

comment:12 Changed 8 years ago by livings124

So you're using the Web interface?

comment:13 Changed 8 years ago by emoxam

Yes

comment:14 Changed 8 years ago by livings124

  • Component changed from Transmission to Web Client

comment:15 Changed 8 years ago by emoxam

I don't think it concerns to web client.

  1. because transmission-daemon don't allow to rename torrents in a list.
  2. that's why not 'web client' nor 'transmission remote GUI' (which i prefer more) don't allow to rename torrents in a list.

comment:16 Changed 8 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a duplicate of #5510, which is more concise.

Note: See TracTickets for help on using tickets.