Opened 7 years ago

Closed 7 years ago

#5465 closed Bug (fixed)

Add possibility to build against both Qt 4 and Qt 5

Reported by: mike.dld Owned by: jordan
Priority: Normal Milestone: 2.83
Component: Qt Client Version: 2.82
Severity: Normal Keywords: backport-2.8x
Cc:

Description

With recent 2.82 release, building against Qt 4 was broken. The patch attached makes it possible to use either Qt 4 or Qt 5, depending on the version installed (and qmake used, if both are available).

Attachments (1)

build-against-qt-4-and-5.patch (2.5 KB) - added by mike.dld 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by mike.dld

comment:1 Changed 7 years ago by jordan

  • Milestone changed from None Set to 2.83
  • Status changed from new to assigned

This is a good idea. Thanks for the patch!

comment:2 Changed 7 years ago by jordan

  • Keywords backport-2.8x added
  • Resolution set to fixed
  • Status changed from assigned to closed

Merged r14163

Note: See TracTickets for help on using tickets.