Opened 8 years ago

Closed 7 years ago

#5466 closed Enhancement (duplicate)

Skip verification queuing for non-existent torrents

Reported by: mmayer Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.82
Severity: Normal Keywords: verification
Cc:

Description

I have noticed that Transmission will queue newly added torrents for verification if there's a torrent already undergoing verification. This is done even if the added torrents are new and therefore there's no need to verify anything. Those torrents could instead start downloading while the original torrent is being verified, rather than wait for extended periods of time just to complete "verification" in a split-second once their turn in the verification queue arrives.

I am attaching a patch to verify.c that seems to address the problem.

I tried this out on a Mac using the latest Transmission from the subversion repo, and it performed as expected. If I add a new torrent while another torrent is being verified, the new torrent will start downloading right away.

Attachments (1)

verify.c.patch (708 bytes) - added by mmayer 8 years ago.
Patch for tr_verifyAdd()

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by mmayer

Patch for tr_verifyAdd()

comment:1 Changed 7 years ago by cfpp2p

duplicate of #4034

comment:2 Changed 7 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.