Opened 8 years ago

Closed 7 years ago

#5467 closed Bug (fixed)

transmission-daemon SEGFAULTs on startup without error message if ~/.config does not exist and ~ is not writeable

Reported by: jaseg Owned by: jordan
Priority: Normal Milestone: 2.83
Component: Daemon Version: 2.81
Severity: Minor Keywords: patch
Cc:

Description

Backtrace:

[torrent@newton ~]$ gdb transmission-daemon -ex 'run --foreground'
GNU gdb (GDB) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/transmission-daemon...(no debugging symbols found)...done.
Starting program: /usr/bin/transmission-daemon --foreground
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7ffff62a4700 (LWP 28127)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff62a4700 (LWP 28127)]
0x00007ffff69f01e9 in readdir64 () from /usr/lib/libc.so.6
(gdb) bt
#0  0x00007ffff69f01e9 in readdir64 () from /usr/lib/libc.so.6
#1  0x00000000004086d8 in ?? ()
#2  0x000000000040a458 in ?? ()
#3  0x0000000000416f7e in ?? ()
#4  0x00007ffff799e954 in event_base_loop () from /usr/lib/libevent-2.0.so.5
#5  0x0000000000417040 in ?? ()
#6  0x0000000000407a3a in ?? ()
#7  0x00007ffff6cf0062 in start_thread () from /usr/lib/libpthread.so.0
#8  0x00007ffff6a22a2d in clone () from /usr/lib/libc.so.6

I'm sorry for the lack of debug symbols.

The expected behavior would be to print an error message and exit gracefully.

Creating and chowning ~/.config solves the problem.

Attachments (1)

5467-readonly-home-segfault.patch (491 bytes) - added by mike.dld 7 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 8 years ago by jordan

  • Milestone changed from None Set to 2.90
  • Owner set to jordan
  • Severity changed from Normal to Minor
  • Status changed from new to assigned

I agree this should be fixed since we should try to never let T crash... but still... that's one crazy use case. :)

Changed 7 years ago by mike.dld

comment:2 Changed 7 years ago by mike.dld

  • Keywords patch added

Patch as simple as the attached one fixes the issue for me.

comment:3 Changed 7 years ago by jordan

  • Milestone changed from 2.90 to 2.83
  • Resolution set to fixed
  • Status changed from assigned to closed

Well, since there's an small, safe patch at hand, let's do this for the next release instead of 2.90.

Thanks for chasing this down, mike.dld. :)

Patched in r14240.

Note: See TracTickets for help on using tickets.