Opened 8 years ago

Closed 7 years ago

#5485 closed Bug (worksforme)

Transmission 2.82 QT4 crashes with Sig 11 on FreeBSD 9-STABLE.

Reported by: mikej Owned by: jordan
Priority: Normal Milestone: None Set
Component: Qt Client Version: 2.82
Severity: Blocker Keywords:
Cc:

Description

Hello,

I updated transmission from 2.80 to 2.82 today, it now dumps core.

$ transmission-qt QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave. Segmentation fault: 11 (core dumped)

Compiled using Clang 3.3 on 9.2-PRERELEASE #0: Tue Aug 20 18:42:26 EDT 2013.

Below is a simple backtrace, I'm no expert at debugging so any suggestions are welcome. It should be noted that the cli version works fine, i have tried recompiling all the qt4 stuff and transmission but same sig 11 happens.

#0 0x00000008014431df in evbuffer_expand_singlechain () from /usr/local/lib/event2/libevent-2.0.so.6 [New Thread 807407400 (LWP 101261/transmission-qt)] (gdb) bt #0 0x00000008014431df in evbuffer_expand_singlechain () from /usr/local/lib/event2/libevent-2.0.so.6 #1 0x00000008014430e7 in evbuffer_reserve_space () from /usr/local/lib/event2/libevent-2.0.so.6 #2 0x00000000004b2fd7 in jsonStringFunc (val=<value optimized out>, vdata=0x7fffffffce90) at variant-json.c:533 #3 0x00000000004af9b8 in tr_variantWalk (v=<value optimized out>, walkFuncs=0x512900, user_data=<value optimized out>,

sort_dicts=<value optimized out>) at variant.c:828

#4 0x00000000004b2e81 in tr_variantToBufJson (top=0x0, buf=0x80a046e40, lean=<value optimized out>) at variant-json.c:641 #5 0x00000000004b0550 in tr_variantToBuf (v=<value optimized out>, fmt=<value optimized out>) at variant.c:1111 #6 0x00000000004b05a2 in tr_variantToStr (v=0x0, fmt=24, len=0x0) at variant.c:1123 #7 0x0000000000475bb4 in Session::refreshSessionStats (this=0x80755c780) at session.cc:662 #8 0x000000000047a6e5 in StatsDialog? (this=<value optimized out>, session=<value optimized out>, parent=<value optimized out>)

at stats-dialog.cc:60

#9 0x000000000044c031 in TrMainWindow? (this=0x807407c00, session=@0x80755c780, prefs=@0x8076fd400, model=@0x807569640,

minimized=false) at mainwin.cc:123

#10 0x0000000000426b58 in MyApp? (this=0x7fffffffd680, argc=@0x7fffffffd830, argv=0x7fffffffd801) at app.cc:173 #11 0x0000000000429a2b in main (argc=1, argv=<value optimized out>) at app.cc:537

Here is also a truss run.

stat("/usr/local/share/icons/gnome/scalable/emblems/window-close.png",0x7fffffffb6b0) ERR#2 'No such file or directory' stat("/usr/local/share/icons/gnome/scalable/mimetypes/window-close.png",0x7fffffffb6b0) ERR#2 'No such file or directory' stat("/usr/local/share/icons/gnome/scalable/places/window-close.png",0x7fffffffb6b0) ERR#2 'No such file or directory' stat("/usr/local/share/icons/gnome/scalable/status/window-close.png",0x7fffffffb6b0) ERR#2 'No such file or directory' write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) lstat("/usr/local/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf",{ mode=-r--r--r-- ,inode=3854559,size=693876,blksize=32768 }) = 0 (0x0) open("/usr/local/lib/X11/fonts/dejavu/DejaVuSans-Bold.ttf",O_RDONLY,00) = 10 (0xa) fcntl(10,F_SETFD,FD_CLOEXEC) = 0 (0x0) fstat(10,{ mode=-r--r--r-- ,inode=3854559,size=693876,blksize=32768 }) = 0 (0x0) mmap(0x0,693876,PROT_READ,MAP_PRIVATE,10,0x0) = 34531704832 (0x80a400000) close(10) = 0 (0x0) sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0) sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0) sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0) sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0) sigprocmask(SIG_BLOCK,0x0,0x0) = 0 (0x0) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) write(5,"\A",1) = 1 (0x1) SIGNAL 11 (SIGSEGV) process exit, rval = 0

Thanks.

Change History (1)

comment:1 Changed 7 years ago by mike.dld

  • Resolution set to worksforme
  • Status changed from new to closed

Unable to reproduce on FreeBSD 9.2-RELEASE amd64 compiled with both gcc 4.2.1 and clang 3.3, with all the dependencies installed via pkg_add (qt4, curl, openssl, libevent2) and latest ports tree (at the time of writing). Any additional information?

Note: See TracTickets for help on using tickets.