Opened 8 years ago

Closed 7 years ago

#5508 closed Bug (invalid)

Tray icon of Qt-Client not shown

Reported by: Bugmenot Owned by: jordan
Priority: Normal Milestone: None Set
Component: Qt Client Version: 2.82
Severity: Normal Keywords: qt tray icon xfce lxde
Cc:

Description

I'm running the Qt client on Arch Linux using Qt 5.1.1. The update from v2.81 (14128) to v2.82 (14160) broke the tray icon, it's no longer displayed even though transmission is running fine and don't gives any error-related output in terminal. The bug still exists in the last nightly build (14206), the v2.82 Gtk client is not effected. The bug occurs on Xfce and LXDE.

% transmission-qt
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
libpng warning: iCCP: known incorrect sRGB profile

Change History (5)

comment:1 Changed 8 years ago by cedeel

I would like to see this fixed.

comment:2 Changed 8 years ago by mike.dld

QSystemTrayIcon seems to be completely broken in Qt 5. See Qt bug-tracker.

So you should have better luck punching/patching upstream and sticking to Qt 4 for now.

Last edited 8 years ago by mike.dld (previous) (diff)

comment:3 Changed 7 years ago by mike.dld

Please check if this is still an issue with latest Qt 5 release (5.3.2 currently).

comment:4 Changed 7 years ago by equeim

Tray icon still not working with Qt 5.3.2

comment:5 Changed 7 years ago by mike.dld

  • Resolution set to invalid
  • Status changed from new to closed

I still think the issue is not in Transmission and there's not much we can do. QTBUG-31762 mentions some patch currently in the works, but Qt 5.4.0 strangely still doesn't show the icon (actually it does, but it only happens like one in twenty times for me).

Note: See TracTickets for help on using tickets.