Opened 7 years ago

Closed 6 years ago

#5512 closed Enhancement (duplicate)

Missing "message-location": field in settings.json

Reported by: x190 Owned by:
Priority: High Milestone: None Set
Component: Daemon Version: 2.82
Severity: Normal Keywords: log file, settings.json
Cc:

Description

One can spend a lot of time looking for a crucial logfile that apparently often never gets generated unless specifically requested via "--logfile". This needs to be configurable via the settings.json file.

"lpd-enabled": false, "message-level": 2, "message-location": "<path to logfile>", <---- "peer-congestion-algorithm": "",

I'm guessing that logging is always enabled, but, if that's not true, then we also need:

"message-logging-enabled": true,

Change History (6)

comment:1 follow-up: Changed 7 years ago by jordan

  • Resolution set to incomplete
  • Status changed from new to closed

I don't know what you mean by this? I don't see the string "message-location" anywhere in the code.

comment:2 in reply to: ↑ 1 Changed 7 years ago by x190

Replying to jordan:

... I don't see the string "message-location" anywhere in the code.

That's why I opened the ticket. Running the daemon on OS X produces no log file that I can find. Is '--logfile' expected to be used to generate a log?

comment:3 Changed 6 years ago by x190.303cal

Duplicate of #3432.

comment:4 Changed 6 years ago by x190.303cal

  • Resolution incomplete deleted
  • Status changed from closed to reopened

comment:5 Changed 6 years ago by x190.303cal

See #3432.

comment:6 Changed 6 years ago by x190.303cal

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.