Opened 8 years ago

Closed 7 years ago

#5515 closed Bug (duplicate)

SVN version of Transmission could abort during download due to assertion.

Reported by: pathetic_loser Owned by:
Priority: High Milestone: None Set
Component: Transmission Version: 2.82+
Severity: Critical Keywords: crash assertion
Cc:

Description

When downloading certain torrents, current SVN version of Transmission could encounter weird abort due to assertion failure.

Backtrace follows:


Program received signal SIGABRT, Aborted. [Switching to Thread 0x7f0d89ad5700 (LWP 24712)] 0x00007f0d9738f037 in GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56 56 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory. (gdb) bt #0 0x00007f0d9738f037 in GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56 #1 0x00007f0d97392698 in GI_abort () at abort.c:90 #2 0x00007f0d97387e03 in assert_fail_base (fmt=0x7f0d974de578 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x4e3aad "!tr_peerIsSeed (&msgs->peer)",

file=file@entry=0x4e3986 "peer-msgs.c", line=line@entry=706, function=function@entry=0x4e4910 <PRETTY_FUNCTION.9872> "tr_peerMsgsCalculateActive") at assert.c:92

#3 0x00007f0d97387eb2 in GI_assert_fail (assertion=0x4e3aad "!tr_peerIsSeed (&msgs->peer)", file=0x4e3986 "peer-msgs.c", line=706,

function=0x4e4910 <PRETTY_FUNCTION.9872> "tr_peerMsgsCalculateActive") at assert.c:101

#4 0x00000000004a01b8 in tr_peerMsgsCalculateActive (msgs=0x7f0d4695a930, direction=TR_CLIENT_TO_PEER) at peer-msgs.c:706 #5 0x00000000004a03ba in tr_peerMsgsUpdateActive (msgs=0x7f0d4695a930, direction=TR_CLIENT_TO_PEER) at peer-msgs.c:760 #6 0x00000000004a2574 in readBtMessage (msgs=0x7f0d4695a930, inbuf=0x7f0d473cc970, inlen=111) at peer-msgs.c:1521 #7 0x00000000004a1c63 in readBtId (msgs=0x7f0d4695a930, inbuf=0x7f0d473cc970, inlen=112) at peer-msgs.c:1306 #8 0x00000000004a322a in canRead (io=0x7f0d47713d60, vmsgs=0x7f0d4695a930, piece=0x7f0d89ad4708) at peer-msgs.c:1766 #9 0x0000000000491da0 in canReadWrapper (io=0x7f0d47713d60) at peer-io.c:206 #10 0x0000000000494ba2 in tr_peerIoTryRead (io=0x7f0d47713d60, howmuch=2700) at peer-io.c:1249 #11 0x0000000000495033 in tr_peerIoFlush (io=0x7f0d47713d60, dir=TR_PEER_TO_CLIENT, limit=3000) at peer-io.c:1321 #12 0x00000000004868c6 in phaseOne (peerArray=0x7f0d89ad4ac0, dir=TR_PEER_TO_CLIENT) at bandwidth.c:223 #13 0x0000000000486af6 in tr_bandwidthAllocate (b=0x232e930, dir=TR_PEER_TO_CLIENT, period_msec=500) at bandwidth.c:277 #14 0x000000000049db76 in bandwidthPulse (foo=-1, bar=1, vmgr=0x7f0d80001a70) at peer-mgr.c:3622 #15 0x00007f0d984ad744 in event_base_loop () from /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5 #16 0x00000000004702cf in libeventThreadFunc (veh=0x2327d20) at trevent.c:249 #17 0x0000000000451861 in ThreadFunc? (_t=0x2327f80) at platform.c:108 #18 0x00007f0d97727f8e in start_thread (arg=0x7f0d89ad5700) at pthread_create.c:311 #19 0x00007f0d97451e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113 (gdb) bt full #0 0x00007f0d9738f037 in GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56

resultvar = 0 pid = 24709 selftid = 24712

#1 0x00007f0d97392698 in GI_abort () at abort.c:90

save_stage = 2 act = {sigaction_handler = {sa_handler = 0x7fffa0ae941b, sa_sigaction = 0x7fffa0ae941b}, sa_mask = {val = {139696349751588, 5126534, 706, 0, 139696348371089, 139696121136256,

140735889183894, 2147490624, 4, 139696121136160, 0, 0, 0, 139696349750931, 139696396550144, 139696349767032}}, sa_flags = 5126829, sa_restorer = 0x4e4910 <PRETTY_FUNCTION.9872>}

sigs = {val = {32, 0 <repeats 15 times>}}

#2 0x00007f0d97387e03 in assert_fail_base (fmt=0x7f0d974de578 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=assertion@entry=0x4e3aad "!tr_peerIsSeed (&msgs->peer)",

file=file@entry=0x4e3986 "peer-msgs.c", line=line@entry=706, function=function@entry=0x4e4910 <PRETTY_FUNCTION.9872> "tr_peerMsgsCalculateActive") at assert.c:92

str = 0x7f0d834a0b50 "" total = 4096

#3 0x00007f0d97387eb2 in GI_assert_fail (assertion=0x4e3aad "!tr_peerIsSeed (&msgs->peer)", file=0x4e3986 "peer-msgs.c", line=706,

function=0x4e4910 <PRETTY_FUNCTION.9872> "tr_peerMsgsCalculateActive") at assert.c:101

No locals. #4 0x00000000004a01b8 in tr_peerMsgsCalculateActive (msgs=0x7f0d4695a930, direction=TR_CLIENT_TO_PEER) at peer-msgs.c:706

is_active = true PRETTY_FUNCTION = "tr_peerMsgsCalculateActive"

#5 0x00000000004a03ba in tr_peerMsgsUpdateActive (msgs=0x7f0d4695a930, direction=TR_CLIENT_TO_PEER) at peer-msgs.c:760

is_active = false

#6 0x00000000004a2574 in readBtMessage (msgs=0x7f0d4695a930, inbuf=0x7f0d473cc970, inlen=111) at peer-msgs.c:1521

ui32 = 32525 msglen = 0 id = 2 '\002' startBufLen = 111 fext = true PRETTY_FUNCTION = "readBtMessage"

#7 0x00000000004a1c63 in readBtId (msgs=0x7f0d4695a930, inbuf=0x7f0d473cc970, inlen=112) at peer-msgs.c:1306

id = 2 '\002'

#8 0x00000000004a322a in canRead (io=0x7f0d47713d60, vmsgs=0x7f0d4695a930, piece=0x7f0d89ad4708) at peer-msgs.c:1766

ret = READ_LATER msgs = 0x7f0d4695a930 in = 0x7f0d473cc970 inlen = 112 PRETTY_FUNCTION = "canRead"

#9 0x0000000000491da0 in canReadWrapper (io=0x7f0d47713d60) at peer-io.c:206

oldLen = 112 ret = 0 overhead = 0 piece = 0 used = 4 now = 1381513029557 err = false done = false session = 0x232e720 PRETTY_FUNCTION = "canReadWrapper"

#10 0x0000000000494ba2 in tr_peerIoTryRead (io=0x7f0d47713d60, howmuch=2700) at peer-io.c:1249

e = 0 res = 237

#11 0x0000000000495033 in tr_peerIoFlush (io=0x7f0d47713d60, dir=TR_PEER_TO_CLIENT, limit=3000) at peer-io.c:1321

bytesUsed = 0 PRETTY_FUNCTION = "tr_peerIoFlush"

#12 0x00000000004868c6 in phaseOne (peerArray=0x7f0d89ad4ac0, dir=TR_PEER_TO_CLIENT) at bandwidth.c:223

i = 88 increment = 3000 bytesUsed = 0 n = 279 peerCount = 304

---Type <return> to continue, or q <return> to quit---

peers = 0x7f0d81587b60

#13 0x0000000000486af6 in tr_bandwidthAllocate (b=0x232e930, dir=TR_PEER_TO_CLIENT, period_msec=500) at bandwidth.c:277

i = 304 peerCount = 304 tmp = {items = 0x7f0d46f5f090, n_items = 304, n_alloc = 512} low = {items = 0x7f0d82e2afe0, n_items = 304, n_alloc = 512} high = {items = 0x0, n_items = 0, n_alloc = 0} normal = {items = 0x7f0d81587b60, n_items = 304, n_alloc = 512} peers = 0x7f0d46f5f090

#14 0x000000000049db76 in bandwidthPulse (foo=-1, bar=1, vmgr=0x7f0d80001a70) at peer-mgr.c:3622

tor = 0x39de00bc mgr = 0x7f0d80001a70 session = 0x232e720

#15 0x00007f0d984ad744 in event_base_loop () from /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5 No symbol table info available. #16 0x00000000004702cf in libeventThreadFunc (veh=0x2327d20) at trevent.c:249

base = 0x7f0d800008f0 eh = 0x2327d20

#17 0x0000000000451861 in ThreadFunc? (_t=0x2327f80) at platform.c:108

t = 0x2327f80

#18 0x00007f0d97727f8e in start_thread (arg=0x7f0d89ad5700) at pthread_create.c:311

res = <optimized out> pd = 0x7f0d89ad5700 now = <optimized out> unwind_buf = {cancel_jmp_buf = {{jmp_buf = {139696121140992, 9018781853608000421, 0, 139696396578912, 139696352204608, 4096, -8993067139784295515, -8993115975144096859}, mask_was_saved = 0}},

priv = {pad = {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}

not_first_call = 0 pagesize_m1 = <optimized out> sp = <optimized out> freesize = <optimized out> PRETTY_FUNCTION = "start_thread"

#19 0x00007f0d97451e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113 No locals.

Attachments (1)

planet-latest.osm.pbf.torrent (109.2 KB) - added by pathetic_loser 8 years ago.
Sample torrent which can cause crash during download.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by pathetic_loser

Sample torrent which can cause crash during download.

comment:1 Changed 8 years ago by x190

Webseed(?) crasher: #5505

comment:2 Changed 7 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #5505

Note: See TracTickets for help on using tickets.