Opened 8 years ago

Last modified 6 years ago

#5516 reopened Bug

SVN version of Transmission aborted when verifying torrent.

Reported by: pathetic_loser Owned by:
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.82+
Severity: Normal Keywords: SVN assertion abort verify
Cc:

Description

I've attempted to run verify on partially downloaded torrent from my previous ticket (OSM planet file, torrent attached to #5515 if needed). Transmission encountered assertion failure at this point:

transmission-gtk: bitfield.c:157: tr_bitfieldIsValid: Assertion `!b->bits || (b->true_count == countArray (b))' failed.

Unlike previous bug, this error not seems to be related to webseeds on its own and seems to be bug in torrent verification instead.

Change History (2)

comment:1 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4508.

comment:2 Changed 6 years ago by mike.dld

  • Component changed from Transmission to libtransmission
  • Priority changed from High to Normal
  • Resolution duplicate deleted
  • Severity changed from Critical to Normal
  • Status changed from closed to reopened

Reopening to address this issue separately.

See also ​https://forum.transmissionbt.com/viewtopic.php?f=4&t=17334 (reproduced on current nightly r14560).

Note: See TracTickets for help on using tickets.