Opened 14 years ago

Closed 12 years ago

#554 closed Bug (duplicate)

File -> Move Data hangs the entire interface

Reported by: Demio Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 0.96
Severity: Major Keywords:
Cc: leroy.bodacious@…

Description

Running the File -> Move Data on any data hangs the entire interface until the move is done.

This is bad considering sometimes torrents can be over 15GiB, and moving that kind of information usually takes some minutes, and hanging the entire application to the eyes of the user is a bad thing, especially when it's for such a huge amount of time.

This move should occur in a separate thread to avoid these kind of hangs.

Change History (7)

comment:1 Changed 13 years ago by turbo

I was thinking about this very thing when I made a patch for #920...

But I decided against it because how would the 'Move done' message be done? Popup? Removing the Download progress bar with a Move progress bar (with a different color)?

comment:2 Changed 13 years ago by charles

IMO the proper fix to this bug is going to have to dovetail with #1521, #651, and #920. I think what we really need is a worker thread to handle all IO requests asynchronously from the libtransmission thread's point of view. That's a big task, but would fix these important tickets...

comment:3 Changed 13 years ago by turbo

See #1753. I don't know if Trac can do it, or if it's me that don't have the access, but I couldn't seem to do a 'Depend on Bug'.

comment:4 Changed 13 years ago by charles

Trac can't do it afaik.

comment:5 Changed 13 years ago by j3r3miah

  • Cc leroy.bodacious@… added

comment:6 Changed 13 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

Now that move data is in the core, this applies to all the UI's. The mac code will be moving to use the new libT code soon.

comment:7 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a subset/duplicate of #1753.

Note: See TracTickets for help on using tickets.