Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5540 closed Bug (invalid)

NFS server error...

Reported by: leandroong Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.82+
Severity: Normal Keywords:
Cc:

Description

using latest nightly build, 14215 Problem: Transmission crashing when specified download directory use is NFS server, acting as main router. This is my setup and observations: 1.) mount tomato router as NFS client using syntax "mount -t nfs -o nolock,intr,hard,timeo=14,rsize=8192,wsize=8192 10.0.1.1:/media/AiDisk_a2/downloads /mnt/downloads" 2.) Start 1 torrent download. It stopped at about 13.6MB/45MB completion. Transmission crash, transmission web still up but no sign of activity. 3.) Restart transmission. Downloading start at 0MB, it does not consider data saved on NFS server. It will halt operation again, not ending on same MB download size. 4.) Restart transmission, pause and trash torrent. NFS server partial data was still there.

Not sure if this is transmission error or NFS configuratio error. 4.)

Change History (3)

comment:1 Changed 8 years ago by leandroong

from log it says NFS server not responding. I guess this is probably invalid issue. just delete it

comment:2 Changed 8 years ago by rb07

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 8 years ago by leandroong

Solved. I use this syntax to mount NFS client and works well with transmission.

  1. mkdir /mnt/downloads
  2. mount -t nfs -o nolock,intr,hard,timeo=14,sync 10.0.1.1:/media/AiDisk_a2/downloads /mnt/downloads

note: sync, waits for NFS server writes completion and that solved "NFS server not responding..."

This is just addl info for those interested. This issue is closed and invalid.

Note: See TracTickets for help on using tickets.