Opened 9 years ago

Closed 8 years ago

#5544 closed Enhancement (fixed)

Request for automatic spam control on the forum

Reported by: rb07 Owned by: John Clay
Priority: Normal Milestone: None Set
Component: Website Version:
Severity: Normal Keywords: Spam
Cc: robert.vehse@…

Change History (17)

comment:1 Changed 9 years ago by Robby

  • Cc robert.vehse@… added

comment:2 Changed 9 years ago by John Clay

We already use a number of anti-spam methods, but obviously that wasn't sufficient. I've upgraded phpBB to the latest version, installed a new CAPTCHA during registration, and enabled an anti-spam question. Hopefully, these combined will reduce the number of successful bot registrations.

comment:3 Changed 9 years ago by John Clay

  • Version 2.82 deleted

comment:4 Changed 9 years ago by John Clay

  • Status changed from new to assigned

comment:5 Changed 8 years ago by John Clay

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 8 years ago by cfpp2p

  • Resolution fixed deleted
  • Status changed from closed to reopened

The forum seems heavily spammed again :( https://forum.transmissionbt.com/search.php?keywords=[the|and]&terms=all&author=&sc=1&sf=all&sr=topics&sk=t&sd=d&st=0&ch=300&t=0&submit=Search Makes it a little difficult to sort through the junk. I'm not sure what can be done, perhaps only allow accredited members the ability to place hyper links, not really sure. Hopefully someone can come up with a good idea.

comment:7 Changed 8 years ago by x190

Mother used to say "moderation in all things". I may have gone astray anyway, but still, that is what we need here. Therefore and thusly, I hereby nominate cfpp2p as forum moderator, with my oversight of course.

comment:8 Changed 8 years ago by cfpp2p

This ticket was suggesting "automatic spam control" might be a solution and that's what I was in line with. A manual implementation might help too. rb07 included several ideas in the description as a starting point and John Clay installed and enabled some features, but we are still deluged by spam for some reason.

comment:9 Changed 8 years ago by x190

The forum has always been "deluged by spam". The problem is that there is no forum moderator to delete spammer accounts immediately. We don't need those horrible indecipherable captcha type deterrents that only shut out legitimate posters.

comment:10 Changed 8 years ago by Robby

A spambot countermeasure which seems to work well is the Q&A plugin.

For every form submission where you have enabled the Q&A plugin, users will be asked one of the questions specified here. To use this plugin at least one question must be set in the default language. These questions should be easy for your target audience to answer but beyond the ability of a bot capable of running a Google™ search. Using a large and regularly changed set of questions will yield the best results. Enable the strict setting if your question relies on mixed case, punctuation or whitespace.

Last edited 8 years ago by Robby (previous) (diff)

comment:11 Changed 8 years ago by John Clay

I've deleted all of the reported spam on the forum (and their users). I've also switched back to the Q&A anti-spam, with a hopefully more obscure/hard to automate answer than the last time we used it.

I'm open to suggestions for good questions, too. If you see more spam on the forum, please report it and update this ticket.

Thanks.

comment:12 follow-up: Changed 8 years ago by x190

Just what you were looking for --- right JC? *lol* Ways to Recycle Your Prom Dress

Last edited 8 years ago by x190 (previous) (diff)

comment:13 in reply to: ↑ 12 Changed 8 years ago by John Clay

Replying to x190:

Just what you were looking for --- right JC? *lol* Ways to Recycle Your Prom Dress

Just what I always wanted!

It looks like, however, all of the recent spam posts have been from accounts made before the latest tweak. Hopefully it stays that way.

comment:14 follow-up: Changed 8 years ago by Robby

Yay! That’s the way it went the forum I am an admin on. On the plus side, those spam posts help identify remaining spam accounts.

Version 0, edited 8 years ago by Robby (next)

comment:15 in reply to: ↑ 14 Changed 8 years ago by x190

Replying to Robby:

Yay! That’s the way it went with the forum I am an admin on. On the plus side, those spam posts help identify remaining spam accounts.

A moderate amount of moderation would help.

comment:16 Changed 8 years ago by Robby

I would be willing to help out.

comment:17 Changed 8 years ago by jordan

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.