Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5551 closed Bug (wontfix)

Transmission regularly gains keyboard focus and main window comes to front

Reported by: kabadesu Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.82
Severity: Major Keywords:
Cc:

Description

It appears that, even though I have used every option to prevent Transmission requiring any use input when adding torrents, the main window brings itself to the front of the screen and steals keyboard focus.

This is especially frustrating during a movie or TV show where I am unable to quickly pause the video using the keyboard to deal with Transmission.

Ideally the window should never come to the front unless the use has checked an option for that to happen.

Latest stable nightly. OSX Mavericks 10.9

Change History (9)

comment:1 Changed 8 years ago by livings124

What are you doing to cause it to gain focus?

comment:2 Changed 8 years ago by livings124

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:3 Changed 8 years ago by kabadesu

Nothing. I'm just watching movies and all of a sudden the Transmission window jumps to the front. I'm guessing it's when it detects a new torrent file, downloaded by Automatic, but Transmission shouldn't need to come to the front. I've switched off any options that cause a prompt. Is there any way to suppress the Transmission window?

comment:4 Changed 8 years ago by livings124

If Automatic is calling the app, there's not much we can do. Transmission does show the main window when clicking the app in the dock, as it should. My guess is Automatic is triggering it that way.

comment:5 Changed 8 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

comment:6 Changed 8 years ago by x190

Confirmed that this is not an issue caused by Transmission itself.

kabadesu, suggest you contact the Automatic developer.

Last edited 8 years ago by x190 (previous) (diff)

comment:7 Changed 8 years ago by kabadesu

Well Automatic doesn't actually do anything to Transmission. Automatic downloads new torrent files to a folder, independent of Transmission. Transmission is monitoring the folder and then Transmission is adding the torrents to the main window. It's all to do with Transmission.

Please reconsider fixing as it's not a problem with Automatic.

comment:8 Changed 8 years ago by x190

kabadesu, my tests were done by manually adding torrent files to the watch folder on 10.6.8. Perhaps 10.9 behaves differently. Have you tried a similar test?

comment:9 Changed 8 years ago by kabadesu

Thanks for taking the time to check this further. I tried what you suggested and got the same result as you (no main window). I have a feeling that the issue could be caused by magnet links from ShowRSS and am trying a feed with magnets disabled. I think you were right all along and I'm sorry I didn't think to look at Automatic's options further. I had forgotten that the application even had settings beyond which feed to monitor and which folder to download to.

Note: See TracTickets for help on using tickets.