Opened 7 years ago

Closed 6 years ago

#5563 closed Bug (duplicate)

cppcheck errors

Reported by: rahulsundaram Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.82
Severity: Normal Keywords:
Cc:

Description

I was playing around with cppcheck and found the following problems in Transmission

[gtk/tr-icon.c:24]: (error) syntax error [gtk/tr-window.c:69]: (error) syntax error [gtk/util.c:658]: (error) syntax error [libtransmission/utils-test.c:370]: (error) Passing value -1 to sqrt() leads to undefined result. [libtransmission/variant.c:868]: (error) Common realloc mistake: 'stack' nulled but not freed upon failure [libtransmission/variant.c:884]: (error) Common realloc mistake: 'stack' nulled but not freed upon failure [third-party/libevent/bufferevent_pair.c:128]: (error) Memory leak: bufev1 [third-party/libutp/utp.cpp:1150]: (error) Common realloc mistake: 'pkt' nulled but not freed upon failure [third-party/libutp/templates.h:116]: (error) Common realloc mistake: 'mem' nulled but not freed upon failure [third-party/miniupnp/miniwget.c:94]: (error) Common realloc mistake: 'header_buf' nulled but not freed upon failure [third-party/miniupnp/miniwget.c:234]: (error) Common realloc mistake: 'content_buf' nulled but not freed upon failure [third-party/miniupnp/miniwget.c:258]: (error) Common realloc mistake: 'content_buf' nulled but not freed upon failure

Change History (2)

comment:1 Changed 7 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to jordan

comment:2 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks, but I'm going to close this as duplicate of #5903 which has a more recent version checked.

Note: See TracTickets for help on using tickets.