Opened 8 years ago

Closed 8 years ago

#5566 closed Bug (worksforme)

Queued for Download Torrents Paused After Restart

Reported by: Renara Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.82
Severity: Normal Keywords:
Cc:

Description

Mostly as the title says; I'm finding that while running transmission as a daemon under Linux that some or all of my queued for download torrents will be paused after a restart, either of just the daemon itself, or of the whole system.

Unfortunately it's tricky to reproduce; the issue doesn't seem to occur with smaller numbers of torrents, but the reason I enable queuing is that I often accumulate large numbers of torrents that are slow to download, or that I wish to seed to a reasonable ratio.

Here's a sample of some of the settings I have that seem relevant:

download-queue-enabled=true download-queue-size=10 seed-queue-enabled=true seed-queue-size=10 queue-stalled-enabled=true queue-stalled-minutes=5 upload-slots-per-torrent=6

I currently have 86 torrents in my list, with 23 downloading and the rest seeding.

I've gone through Transmission's logs but there doesn't appear to be any relevant error; it's just silently pausing various torrents instead of queueing them to download. So far it mostly affects downloading torrents, but does sometimes appear to affect seeding ones.

My only thought is that with such a large list, Transmission is having some kind of issue saving and restoring state. I don't know how any of that currently works, but perhaps it would be possible to make sure queued torrents have their state saved before Transmission is stopped, and then stagger re-loading of torrents by the time that were last active (so torrents that were queued will be loaded last)? I dunno.

Change History (2)

comment:1 Changed 8 years ago by cfpp2p

It looks like the same as https://trac.transmissionbt.com/ticket/5427#comment:6 fixed in trunk

comment:2 Changed 8 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.