Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#5577 closed Bug (fixed)

Crash on quit (Mac OS X)

Reported by: Robby Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.82
Severity: Normal Keywords: crash, mac, osx
Cc:

Description

Just now, Transmission crashed on quit. The crash is not reproducible for me. I'm attaching the crash log.

This is with Transmission 2.82 on OS X 10.9.1.

Attachments (2)

Transmission crash on quit.txt (58.0 KB) - added by Robby 7 years ago.
transmission crash report.txt (67.0 KB) - added by subju 6 years ago.
Crash report

Download all attachments as: .zip

Change History (19)

Changed 7 years ago by Robby

comment:1 Changed 7 years ago by livings124

  • Resolution set to incomplete
  • Status changed from new to closed

Unfortunately there's not enough information in that crash log. Could you reopen with the crash log from a nightly build from build.transmissionbt.com?

comment:2 Changed 7 years ago by Robby

If the crash were reproducible, I wouldn't mind using the nightly to provide a crash log. But I don't intend to regularly use a potentially unstable build in order to provide useful crash log output, sorry.

Last edited 7 years ago by Robby (previous) (diff)

comment:3 follow-up: Changed 7 years ago by x190

Robby, you have already demonstrated that 2.82 release is not stable for you. What have you got to lose other than helping the devs avoid perpetuating the issue?

See also #5538.

Last edited 7 years ago by x190 (previous) (diff)

comment:4 in reply to: ↑ 3 Changed 7 years ago by Robby

Replying to x190:

Robby, you have already demonstrated that 2.82 release is not stable for you. What have you got to lose other than helping the devs avoid perpetuating the issue?

I hold Transmission and the whole Project in very high regard. I have been using the programme for many years and I can hardly remember any major bugs in all that time. A rare crash on quit will not get my knickers in a twist. ;-)

But nightly builds, aren't they potentially alpha quality pre-release builds? I wouldn't expect data loss or other major regressions but the risk must surely be there (?).

I wouldn't mind using a debug build of 2.82 release or something to that effect. :-)

See also #5538.

Yeah, the same does apply there.

In fact, I wouldn't be surprised if the issue is related to this one because I often pause all torrents before quitting.

comment:5 Changed 7 years ago by livings124

FWIW, the current nightly is pretty much release quality.

comment:6 Changed 7 years ago by Robby

Well, now I'm running a nightly. And guess what happens? I get what looks like a different crash: #5587. :-P

comment:7 Changed 7 years ago by Robby

#5505 is quite a pain. I'm going back to the stable release.

comment:8 Changed 7 years ago by Robby

Only got this crash again just now so it is somewhat rare. I’d go back to the nightly if it wasn’t for #5505.

Last edited 7 years ago by Robby (previous) (diff)

Changed 6 years ago by subju

Crash report

comment:9 Changed 6 years ago by subju

  • Keywords crash mac osx added
  • Resolution incomplete deleted
  • Status changed from closed to reopened
  • Version changed from 2.82 to 2.84

Transmission still frequently crashes on quit. My crash report is in attachment.

comment:10 Changed 6 years ago by subju

  • Summary changed from Crash on quit to Crash on quit (Mac OS X)

Transmission still frequently crashes on quit. Mac OS X 10.10.1 (14B25). The crash report is in attachment.

comment:11 follow-up: Changed 6 years ago by mike.dld

  • Version changed from 2.84 to 2.82

comment:12 Changed 6 years ago by Robby

subju, this ticket was previously closed because a crash log from a nightly build was required…

comment:13 in reply to: ↑ 11 ; follow-up: Changed 6 years ago by subju

Replying to mike.dld: What is the reason for changing the version? The current version (2.84, 14306) have this issue as well.

To moderators: Should I create the same ticket for version 2.84 (14306)?

comment:14 follow-up: Changed 6 years ago by Robby

I believe it’s the policy of this project to use the version an issue was initially reported for. No need to file a new ticket for the same crash.

As mentioned in my previous comment, you probably need to post a crash log from a nightly build (see comment 1 here).

Last edited 6 years ago by Robby (previous) (diff)

comment:15 in reply to: ↑ 13 Changed 6 years ago by mike.dld

Replying to subju:

What is the reason for changing the version? The current version (2.84, 14306) have this issue as well.

Version specifies first (lowest) version exhibiting the behavior. Otherwise it's not clear how long the issue exists.

Should I create the same ticket for version 2.84 (14306)?

No need, unless the issue you're having is different/unrelated (which is yet to be determined).

comment:16 Changed 6 years ago by mike.dld

  • Resolution set to fixed
  • Status changed from reopened to closed

Judging from attached crashlogs,

  • original one (from Robby) could be caused by libevent issue #113 (fixed Mar 26 2014, v2.82 was released Aug 9 2013).
  • new one (from subju) is a different crash, which was reported on forums by jabohn but didn't get much attention although it's not the same as ones discussed in that thread (all related to #5505). It deserves a separate ticket indeed.

For the original issue, I'm not sure when exactly did we pull libevent fix to our local mirror, but current nightlies should not be affected (reopen if I'm wrong).

I'm re-closing this ticket. For issue reported by subju and jabohn, new ticket #5891 created.

comment:17 in reply to: ↑ 14 Changed 6 years ago by subju

Replying to Robby and mike.dld:

Thank you for helpful explanations! I’m sorry for false alarm.

Note: See TracTickets for help on using tickets.