Opened 7 years ago

Closed 7 years ago

#5585 closed Bug (duplicate)

Crash in tr_peerMsgsCalculateActive

Reported by: zorun Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.82+
Severity: Normal Keywords:
Cc:

Description

To solve #5580, I upgraded to r14219, which seemed to solve the issue.

However, transmission-daemon crashed again after a few hours. The issue is probably different, as I was only seeding torrents at the time (136 torrents).

Jan 10 22:30:18 pilipili transmission-daemon[24676]: transmission-daemon: peer-msgs.c:706: tr_peerMsgsCalculateActive: Assertion `!tr_peerIsSeed (&msgs->peer)' failed.
Jan 10 22:30:19 pilipili systemd[1]: transmission.service: main process exited, code=dumped, status=6/ABRT

The system is Archlinux i686, with a custom-built transmission package from r14219 (tarball taken from https://build.transmissionbt.com/job/trunk-linux/).

Change History (2)

comment:1 Changed 7 years ago by x190

See also #5493, #5505, #5515, and #5587.

So you are seeding, but you're connected to a webseed who fails "Assertion `!tr_peerIsSeed (&msgs->peer)"? [See r14114]

Last edited 7 years ago by x190 (previous) (diff)

comment:2 Changed 7 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #5505

Note: See TracTickets for help on using tickets.