Opened 7 years ago

Closed 6 years ago

#5647 closed Bug (worksforme)

Transmission-Daemon crashes on addition/restarting of new torrent

Reported by: Falstaff Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.81+
Severity: Critical Keywords:
Cc:

Description

Transmission-Daemon regularly crashes immediately on addition of certain torrents, or when these torrents are restarted (one of them is the Ubuntu 13.1 installer package). The only message on any verbosity level is 'Killed'

Torrent is Transmission-2.81-oabi freshly installed on a DNS-323 NAS with funplug 0.7 (curl 7.24.0). Issue started after upgrade, Transmission 2.42 worked fine on funplug 0.5.

Apart from searching the forums and trying google-fu for a week now, I have tried:

  • upgrading firmware on DNS-323 and resetting to factory default
  • installing and re-installing all versions of transmission available on slacker/Kylek's site
  • Modifying settings including cache-size and some others
  • EVENT_NOEPOLL=0 (or 1, same difference)

Attached are settings.json and transmission log. Any help would be appreciated.

Attachments (2)

settings.json (2.1 KB) - added by Falstaff 7 years ago.
Settings
transmission-daemon.log (3.0 KB) - added by Falstaff 7 years ago.
Transmission log

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by Falstaff

Settings

Changed 7 years ago by Falstaff

Transmission log

comment:1 Changed 7 years ago by mike.dld

Anything interesting in dmesg upon termination (maybe an out-of-memory kernel warnings)? Is it possible to get a core dump, or backtrace (if gdb is available)?

comment:2 follow-up: Changed 7 years ago by automaciej

It's consistently crashing for me.

Here's information from apport: http://quinoa.blizinski.pl/~maciej/tmp/_usr_bin_transmission-gtk.1000.crash

comment:3 in reply to: ↑ 2 Changed 7 years ago by mike.dld

Replying to automaciej:

It's consistently crashing for me.

Here's information from apport: http://quinoa.blizinski.pl/~maciej/tmp/_usr_bin_transmission-gtk.1000.crash

Looks like another #5437 clone.

comment:4 follow-up: Changed 7 years ago by x190

Falstaff's issue may not be related to that of automaciej. The following forum post, however, does seem to be related.

https://forum.transmissionbt.com/viewtopic.php?f=2&t=15855#p68101

comment:5 in reply to: ↑ 4 Changed 7 years ago by mike.dld

Yeah, I was replying solely to automaciej. Sorry if that was confusing.

comment:6 Changed 7 years ago by jordan

automaciej, please report that bug via launchpad and paste that bug's URL here. launchpad has builtin tools to retrace the .crash file s.t. the developers can see the backtrace and more information on what Transmission was doing when it crashed.

Falstaff, please see mike.dld's questions in comment:1.

comment:7 Changed 7 years ago by automaciej

Filed: https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/1320470

Potentially a duplicate of: https://bugs.launchpad.net/ubuntu/+source/transmission/+bug/1225326

I read a bit more and it looks like crashes are automatically uploaded to errors.ubuntu.com by whoopsie. My crash report should be somewhere in there.

This should be the relevant report: https://errors.ubuntu.com/problem/b5acb72ee0529c71b8a5830b31e81b8e25d1e8d7

...but when I try to access it, errors.ubuntu.com logs me out immediately.

comment:8 Changed 7 years ago by x190

More info here: #5550

comment:9 Changed 6 years ago by mike.dld

@Falstaff, any news?

comment:10 Changed 6 years ago by Falstaff

It kind of stopped doing what it did despite me not changing anything in particular after a couple of weeks. Transmission has run fairly smoothly since then on my DNS-323; if I use it for too long (i.e. > 72 hours) I cannot telnet in at all and have to reboot, which is a completely different kettle of fish.

Thanks for all your efforts and support, anyway!

comment:11 Changed 6 years ago by mike.dld

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for letting us know. Closing for now then.

Note: See TracTickets for help on using tickets.