Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5679 closed Bug (incomplete)

Segmentation fault with Transmission 2.80

Reported by: fturco Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.80
Severity: Normal Keywords:
Cc:

Description

I'm using Transmission 2.80 (GTK+ version) on a Gentoo Linux system. I don't use a more recent version because of (unrelated) bug 5655. I just start Transmission and wait a few seconds, and it crashes. I think the problem is due to a couple of torrents that show the following red error:

Error: no data found! Ensure your drives are connected or use "Set location". To re-download remove the torrent and re-add it.

This is because I previously moved them to another directory. I also tried to use the "Set location" command and specify the right location, but Transmission doesn't see them.

I'm going to attach the backtrace obtained with gdb. To avoid question marks I had to recompile both transmission and libevent with the following options: FEATURES="nostrip", CFLAGS="-march=native -O2 -pipe -ggdb" and CXXFLAGS="-march=native -O2 -pipe -ggdb".


$ emerge -pv transmission

These are the packages that would be merged, in order:

Calculating dependencies... done! [ebuild R ] net-p2p/transmission-2.80-r1::x-portage USE="gtk systemd (-ayatana) -lightweight -qt4 -xfs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Attachments (1)

transmission.log (1.8 KB) - added by fturco 8 years ago.
gdb backtrace

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by fturco

gdb backtrace

comment:1 Changed 8 years ago by jordan

  • Resolution set to incomplete
  • Status changed from new to closed

fturco, 2.80 was released almost a year ago. Does the crash still occur in 2.82 or higher?

comment:2 Changed 8 years ago by fturco

Sorry, I can't reproduce it anymore neither in 2.80 nor in 2.82.

Note: See TracTickets for help on using tickets.