Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5688 closed Bug (fixed)

Updating from 2.82 to 2.83 causes an "improperly signed" error

Reported by: mseymour Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.82+
Severity: Normal Keywords: codesigning
Cc:

Description

When I check for updates in Transmission on OS X 10.9.3, it properly finds the update and allows me to install it.

When I click on "install", it downloads it, and on the verification stage, a dialog appears saying "The update is improperly signed."

Attachments (1)

Screen Shot 2014-05-18 at 10.49.48 PM.png (22.9 KB) - added by mseymour 8 years ago.
Error dialog that appears when validating the update

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by mseymour

Error dialog that appears when validating the update

comment:1 Changed 8 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 8 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed now.

comment:3 Changed 8 years ago by mseymour

Update: I managed to install it via the update framework, but When I relaunched it, it asked me to accept incoming network connections and to allow use of confidential information in Transmission:Remote in my keychain. I would think that would require a second ticket?

Last edited 8 years ago by mseymour (previous) (diff)
Note: See TracTickets for help on using tickets.