Opened 7 years ago

Closed 6 years ago

#5697 closed Bug (invalid)

UDP tracker scrape error

Reported by: cganuelas Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.83
Severity: Blocker Keywords:
Cc: transmission@…

Description

Scrape error when downloading new torrent. Problem started after updating to 2.83 from 2.82

Change History (7)

comment:1 Changed 7 years ago by svetlyo

Same here. I'm getting "Connection failed" for all UDP trackers after updating to 2.83

comment:2 Changed 7 years ago by autosizing

Same problem. Only started after updating to 2.83. Only seems to affect UDP trackers, http trackers seem to be working.

comment:3 Changed 7 years ago by svetlyo

Workaround: change the 'Peer listening port' to something else before closing Transmission. The next time you open it change it back to the desired value - this way you'll avoid the "Error Binding UDP Port " error on startup and the UDP trackers will work again.

comment:4 in reply to: ↑ description Changed 7 years ago by jordan

  • Resolution set to incomplete
  • Status changed from new to closed

Replying to cganuelas:

Scrape error when downloading new torrent. Problem started after updating to 2.83 from 2.82

Thank you for taking the time to report this bug and helping to make Transmission better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

At a minimum, we need:

  1. the specific steps or actions you took that caused you to encounter the problem,
  2. the behavior you expected, and
  3. the behavior you actually encountered (in as much detail as possible).

Thanks!

comment:5 Changed 7 years ago by yamatai

  • Cc transmission@… added
  • Resolution incomplete deleted
  • Status changed from closed to reopened
  • Summary changed from Scrape error to UDP tracker scrape error

Bump. I can provide the information you need.

  1. Add torrent by dragging torrent URL from Chrome to Transmission. Have turned off "start transfers when added" and turned on "display a window when opening torrent file" (only when adding manually), though they are unlikely to have an effect. Then, I OK the window and start the torrent (occasionally will click "start when adding" but usually start manually after adding.
  1. Upon starting the transfer, Transmission should succeed in announcing to UDP trackers.
  1. In the inspector window's "Trackers" tab, if my torrent has more than one tracker, many times there will be one Tier 1 HTTP tracker and 1-2 Tier 2 UDP trackers (or sometimes 1 T2 and 1 T3). For every such UDP tracker, the results are the same: When the torrent is started and the announcement begins, the Tier 1 HTTP tracker returns (almost) immediately. The UDP tracker(s) will change to "announce in progress", and eventually fail with both "Announce error: Connection failed" and "Scrape error: Connection failed". The message log (debug level) has no further useful information.

Throughout the transfer, Transmission continues to attempt announcing to the Tier 2(+) UDP trackers with exponentially larger retry times. Pausing and restarting the torrent has no effect. I cannot report whether this also occurs with Tier 1 UDP trackers, as the sites I torrent from use HTTP tier 1 trackers. I have not tried the workaround mentioned previously.

Mostly irrelevant but included for completeness: In my case, my listening port status is (and always has been) "Port is closed". This ISP-mandated router does not support UPnP nor NAT-PMP, so I have manually forwarded the port. My Mac firewall is currently off. I have tried this in both VPN and non-VPN configurations with the same results. I am running Mac OS X 10.8.5 and connect via WiFi?. I do not use my ISP-provided DNS servers. From the terminal, using the command nc -u -z ‹hostname› ‹port› returns Connection to ‹hostname› ‹port› port [udp/----] succeeded!

Any further information you need I would be glad to provide. Thank you.

comment:6 Changed 6 years ago by JJTagy

Recommend closing this. Valid UDP trackers seem to be connecting fine.

comment:7 Changed 6 years ago by x190

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.