Opened 8 years ago

Closed 7 years ago

#5701 closed Bug (duplicate)

Qt compile in linux failure

Reported by: rosc Owned by: jordan
Priority: Normal Milestone: None Set
Component: Qt Client Version: 2.83
Severity: Normal Keywords: qt compile failure
Cc:

Description

Something broke in the new version.. Tried compiling the last snapshot as well, and get somewhat different errors, but still fails:

~/work/transmission-2.83/qt$ make g++ -c -pipe -g -Wall -W -D_REENTRANT -DQT_DBUS_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/local/qt-4.8.0/mkspecs/linux-g++ -I. -I/usr/local/qt-4.8.0/include/QtCore -I/usr/local/qt-4.8.0/include/QtNetwork -I/usr/local/qt-4.8.0/include/QtGui -I/usr/local/qt-4.8.0/include/QtDBus -I/usr/local/qt-4.8.0/include -I/usr/include -I.. -I/usr/local/include -I. -I. -o mainwin.o mainwin.cc mainwin.cc:1169:3: warning: identifier 'nullptr' is a keyword in C++11 [-Wc++0x-compat] mainwin.cc: In member function 'void TrMainWindow::openTorrent()': mainwin.cc:1168:3: warning: 'auto' changes meaning in C++11; please remove it [-Wc++0x-compat] mainwin.cc:1168:8: error: 'l' does not name a type mainwin.cc:1169:7: error: 'l' was not declared in this scope mainwin.cc:1169:12: error: 'nullptr' was not declared in this scope mainwin.cc:1174:3: error: 'l' was not declared in this scope mainwin.cc: In member function 'void TrMainWindow::removeTorrents(bool)': mainwin.cc:1316:3: warning: 'auto' changes meaning in C++11; please remove it [-Wc++0x-compat] mainwin.cc:1316:8: error: 'layout' does not name a type mainwin.cc:1317:17: error: 'nullptr' was not declared in this scope mainwin.cc:1319:20: error: invalid use of member function (did you forget the '()' ?) mainwin.cc:1320:31: error: no matching function for call to 'QMessageBox::setLayout(<unresolved overloaded function type>)' mainwin.cc:1320:31: note: candidate is: In file included from /usr/local/qt-4.8.0/include/QtGui/qstylepainter.h:47:0,

from /usr/local/qt-4.8.0/include/QtGui/QtGui:20, from mainwin.cc:13:

/usr/lib/qt/include/QtGui/qwidget.h:553:10: note: void QWidget::setLayout(QLayout*) /usr/lib/qt/include/QtGui/qwidget.h:553:10: note: no known conversion for argument 1 from '<unresolved overloaded function type>' to 'QLayout*' mainwin.cc:1323:9: error: invalid use of member function (did you forget the '()' ?) mainwin.cc:1323:9: error: base operand of '->' is not a pointer mainwin.cc:1323:34: error: invalid use of member function (did you forget the '()' ?) mainwin.cc:1323:34: error: base operand of '->' is not a pointer mainwin.cc:1323:61: error: invalid use of member function (did you forget the '()' ?) mainwin.cc:1323:61: error: base operand of '->' is not a pointer make: * [mainwin.o] Error 1

Change History (2)

comment:1 Changed 8 years ago by mike.dld

Duplicate of #5700.

comment:2 Changed 7 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.