Opened 7 years ago

Closed 6 years ago

#5712 closed Bug (duplicate)

conflicting types for 'UTP_Write'

Reported by: helloadam Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.83
Severity: Normal Keywords: UTP_Write
Cc:

Description

Howdy,

Compiling transmission 2.82 and 2.83 on Debian using GCC 4.8.3 results in the following error:

tr-utp.c:66:1: error: conflicting types for ‘UTP_Write’
 UTP_Write (struct UTPSocket *socket, size_t count)
 ^
In file included from tr-utp.c:28:0:
../third-party/libutp/utp.h:116:6: note: previous declaration of ‘UTP_Write’ was here
 bool UTP_Write(struct UTPSocket *socket, size_t count);
      ^
make[1]: *** [tr-utp.o] Error 1
Makefile:1124: recipe for target 'tr-utp.o' failed
make[1]: Leaving directory '/data/apps/source/transmission-2.83/libtransmission'
make: *** [all-recursive] Error 1
Makefile:478: recipe for target 'all-recursive' failed

I believe this is similar to Ticket #5232. You can reproduce this error by using the flag --disable-utp, compiling it with --enable-utp resolves the issue.

Command line options used:

./configure \
	--prefix=$DEST --disable-utp --enable-daemon --with-inotify --without-systemd-daemon \
	--without-gtk --disable-cli

make -j 1

-Adam

Change History (2)

comment:1 Changed 7 years ago by livings124

  • Version changed from 2.82+ to 2.83

comment:2 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5232.

Note: See TracTickets for help on using tickets.