Opened 8 years ago

Last modified 8 years ago

#5726 new Bug

OS X client constantly requesting favicon.png

Reported by: Harry Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.83
Severity: Normal Keywords:
Cc:

Description

Hi, I am not too sure why Transmission is doing this nor do I know what exact component it is, but I have noticed on my server logs that many Transmission clients are (unintentionally) DoSing? my server -- probably from the "trackers" tab adding tracker favicon.

I added an empty orange 1x1 "favicon.png" onto my server because I was annoyed with the constant 404 requests for a favicon.png, but then I noticed that the requests were even more frequent. The clients were requesting the favicon.png constantly even with a 304 response from my server.

I resolved this server-side by making a larger favicon.png, but the bug still exists in the client and it seems like a scary request loop, so I am reporting it!

One of the recent useragents is "Transmission/14283 CFNetwork/673.4 Darwin/13.2.0 (x86_64) (iMac11%2C3)", but it has happened for over a year now from all different flavors of OS X.

I have attached the png I used that caused the client errors, hopefully you are able to reproduce it. I can provide more extensive server logs (for user-agents) at request.

Thanks!

Attachments (1)

favicon.png (95 bytes) - added by Harry 8 years ago.
favicon causing bug

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by Harry

favicon causing bug

comment:1 Changed 8 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124
Note: See TracTickets for help on using tickets.