Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5728 closed Bug (incomplete)

segmentation fault when creating new torrent

Reported by: construidor Owned by: jordan
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.83
Severity: Normal Keywords: segfault segmentation fault crash add torrent gtk
Cc:

Description

When creating a new torrent on GTK interface, transmission crash if a "source folder" is used. Here the Console Output:

(transmission-gtk:11480): Gtk-CRITICAL **: gtk_tree_model_filter_get_value: assertion 'GTK_TREE_MODEL_FILTER (model)->priv->stamp == iter->stamp' failed

(transmission-gtk:11480): GLib-GObject-WARNING **: gtype.c:4210: type id '0' is invalid

(transmission-gtk:11480): GLib-GObject-WARNING **: can't peek value table for type '<invalid>' which is not currently referenced

The crash happens when one of the items "source folder" combo box is selected.

The file "backtrace.txt" (attached), contains the result of:

gdb --batch -ex 'bt full' transmission-gtk core.11427 > backtrace.txt

Attachments (1)

backtrace.txt (2.3 KB) - added by construidor 8 years ago.
Backtrace

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by construidor

Backtrace

comment:1 Changed 8 years ago by jordan

  • Component changed from Transmission to GTK+ Client
  • Owner set to jordan

comment:2 follow-ups: Changed 8 years ago by jordan

  • Resolution set to incomplete
  • Status changed from new to closed

Hurm, three observations:

  1. none of the lines in that backtrace are actually taking place inside of Transmission's code, it's all GTK+.
  2. I'm not able to reproduce the crash: choosing a 'source folder' is working correctly for me here.
  3. None of this code has changed in ages.

Because of these, my initial thought is that it might be a system configuration issue rather than a bug in Transmission. Did you recently upgrade parts of your system? What distro are you using?

comment:3 in reply to: ↑ 2 Changed 8 years ago by construidor

Replying to jordan:

Hurm, three observations:

  1. none of the lines in that backtrace are actually taking place inside of Transmission's code, it's all GTK+.
  2. I'm not able to reproduce the crash: choosing a 'source folder' is working correctly for me here.
  3. None of this code has changed in ages.

Because of these, my initial thought is that it might be a system configuration issue rather than a bug in Transmission. Did you recently upgrade parts of your system? What distro are you using?

Arch Linux, yes I update daily.

comment:4 in reply to: ↑ 2 Changed 8 years ago by construidor

Replying to jordan:

Hurm, three observations:

  1. none of the lines in that backtrace are actually taking place inside of Transmission's code, it's all GTK+.
  2. I'm not able to reproduce the crash: choosing a 'source folder' is working correctly for me here.
  3. None of this code has changed in ages.

Because of these, my initial thought is that it might be a system configuration issue rather than a bug in Transmission. Did you recently upgrade parts of your system? What distro are you using?

It really is a configuration problem, I removed the file ".config/gtk-3.0" and it worked, I will try find what configuration is causing this, but I believe that has no relation to the transmission.

Note: See TracTickets for help on using tickets.