Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5765 closed Bug (invalid)

Torrents with colon in filename fail on Linux system

Reported by: ukoda Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.13
Severity: Minor Keywords:
Cc:

Description

If the filename with in a torrent contains a character that is invalid under Linux, such as colon ':', then downloading will stop with an error "No such file or directory".

I would be nice if the file name could corrected somehow though manual intervention by the downloading user.

Change History (5)

comment:1 Changed 7 years ago by mike.dld

Something else is wrong. Colon is perfectly legal for most (if not all) of *NIX filesystems (in fact, the only forbidden characters are usually forward slash '/' and null '\0'). Could it be that you're downloading to FAT* or NTFS?

comment:2 Changed 7 years ago by mike.dld

I also see that you have specified 2.13 as version having this issue. Please try a more up-to-date version (latest currently is 2.84).

comment:3 Changed 7 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

comment:4 Changed 7 years ago by ukoda

The underlying file system is probably Ext4, but it is on a cifs share on a QNAP NAS as it is used by a range of different client systems. Therefore it is possible that Samba, not Transmission, is the root cause. I will look at testing that tonight. If this is the case then I guess this bug can be closed and I could look at creating a feature request to add a filename modification feature.

The version is that installed with CentOS 6.5. For security reasons I generally stick distribution installed packages by default so that a daily yum update will keep them current. However in cases such as this I am happy to manually install more recent version where the distribution package are known to be significantly out of date. I will look into updating.

comment:5 Changed 7 years ago by mike.dld

Thanks for clarification. If remote filesystem is ext4 then I guess you could also try setting up some more *NIX-friendly network share, e.g. using NFS.

Renaming feature is added since 2.80/2.83 (see Changes). The ticket for handling illegal characters is #4753, but IMHO manual renaming is still preferred.

Note: See TracTickets for help on using tickets.