Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#5781 closed Bug (worksforme)

Transmission causes gnome-shell to freeze

Reported by: wil93 Owned by: jordan
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.84
Severity: Major Keywords: freeze gnome shell
Cc:

Description

I'm using transmission-gtk 2.84 on arch linux. My desktop environment is gnome-shell. Sometimes (when the transmission client is focused) the standard gnome-shell actions (such as ALT+TAB, CTRL+ALT+UP/DOWN) suddenly stop having any effect. When this happens, I notice that I can move the mouse but the system is completely frozen. If I login from another TTY and "killall transmission-gtk", everything goes back to normal.

The current workaround (to avoid interrupting download) is: 1) Login from another TTY 2) Restart gnome-shell by running: "gnome-shell -r -d :0 & disown"

Change ":0" if it doesn't apply to you. Note that "& disown" is only required if you then want to "exit" the TTY.

P.S. I think that the bug is more easily reproducible when *starting* transmission, however I just tried to reproduce it (transmission's uptime: almost 2 days) by doing a lot of ALT+TAB and CTRL+ALT+UP/DOWN + CTRL+SHIFT+ALT+UP/DOWN. I successfully managed to reproduce the bug.

P.P.S. Maybe it should be pointed out that this bug seems similar to #1201, but it cannot be related to that (as I'm not running Mac).

Change History (7)

comment:1 Changed 7 years ago by x190

What actions are you trying to perform on Transmission?

comment:2 Changed 7 years ago by wil93

1) Open some application in a workspace (I used a chat window from empathy) 2) Open transmission-gtk on the workspace below 3) Use ALT+TAB to switch between transmission and the other application (back and forth). Do this several times. 4) gnome-shell should freeze. 5) To restart gnome-shell, open another TTY and run "gnome-shell -r -d :0 & disown"

For completeness, I also reported the bug here: https://bugzilla.gnome.org/show_bug.cgi?id=736283.

comment:3 Changed 7 years ago by x190

That sounds more like a gnome bug than anything to do with Transmission.

comment:4 Changed 7 years ago by wil93

That's why I also reported it to gnome, however, the bug only happens using Transmission.

comment:5 Changed 6 years ago by mike.dld

Is this still happening with recent GNOME versions?

comment:6 Changed 6 years ago by wil93

  • Resolution set to worksforme
  • Status changed from new to closed

I tried to reproduce the bug but I can't do it. It's possible that the bug was fixed.

comment:7 Changed 6 years ago by mike.dld

Thanks for getting back to us.

Note: See TracTickets for help on using tickets.