Opened 7 years ago

Closed 6 years ago

#5785 closed Enhancement (duplicate)

trash&remove data button on toolbar

Reported by: dimonb Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.84
Severity: Normal Keywords: web patch
Cc:

Description

There are no any way to remove torrent and data from mobile device. This patch will add trash button on toolbar.

diff -urN transmission-2.84.orig/web/index.html transmission-2.84/web/index.html
--- transmission-2.84.orig/web/index.html	2014-07-01 21:11:00.646913571 +0400
+++ transmission-2.84/web/index.html	2014-09-04 22:40:36.000000000 +0400
@@ -40,6 +40,7 @@
 		<div id="toolbar">
 			<div id="toolbar-open" title="Open Torrent"></div>
 			<div id="toolbar-remove" title="Remove Selected Torrents"></div>
+			<div id="toolbar-removedata" title="Remove Selected Torrents and Trash Data"></div>
 			<div id="toolbar-separator"></div>
 			<div id="toolbar-start" title="Start Selected Torrents"></div>
 			<div id="toolbar-pause" title="Pause Selected Torrents"></div>
diff -urN transmission-2.84.orig/web/javascript/transmission.js transmission-2.84/web/javascript/transmission.js
--- transmission-2.84.orig/web/javascript/transmission.js	2014-07-01 21:10:59.210913537 +0400
+++ transmission-2.84/web/javascript/transmission.js	2014-09-04 23:06:15.000000000 +0400
@@ -46,6 +46,7 @@
 		$('#toolbar-pause-all').click($.proxy(this.stopAllClicked,this));
 		$('#toolbar-start-all').click($.proxy(this.startAllClicked,this));
 		$('#toolbar-remove').click($.proxy(this.removeClicked,this));
+		$('#toolbar-removedata').click($.proxy(this.removeDataClicked,this));
 		$('#toolbar-open').click($.proxy(this.openTorrentClicked,this));
 
 		$('#prefs-button').click($.proxy(this.togglePrefsDialogClicked,this));
@@ -97,6 +98,7 @@
 		e.toolbar_pause_button      = $('#toolbar-pause')[0];
 		e.toolbar_start_button      = $('#toolbar-start')[0];
 		e.toolbar_remove_button     = $('#toolbar-remove')[0];
+		e.toolbar_removedata_button     = $('#toolbar-removedata')[0];
 		this.elements = e;
 
 		// Apply the prefs settings to the gui
@@ -595,6 +597,13 @@
 		}
 	},
 
+	removeDataClicked: function(ev) {
+		if (this.isButtonEnabled(ev)) {
+			this.removeSelectedTorrentsAndData();
+			this.hideMobileAddressbar();
+		}
+	},
+
 	// turn the periodic ajax session refresh on & off
 	togglePeriodicSessionRefresh: function(enabled) {
 		clearInterval(this.sessionInterval);
@@ -1335,6 +1344,7 @@
 		this.setEnabled(e.toolbar_pause_button,  haveActiveSel);
 		this.setEnabled(e.toolbar_start_button,  havePausedSel);
 		this.setEnabled(e.toolbar_remove_button, haveSel);
+		this.setEnabled(e.toolbar_removedata_button, haveSel);
 	},
 
 	/****
diff -urN transmission-2.84.orig/web/style/transmission/common.css transmission-2.84/web/style/transmission/common.css
--- transmission-2.84.orig/web/style/transmission/common.css	2014-07-01 21:10:53.230913395 +0400
+++ transmission-2.84/web/style/transmission/common.css	2014-09-04 22:58:11.000000000 +0400
@@ -82,6 +82,8 @@
     background-image: url("images/toolbar-folder.png"); }
   div#toolbar > div#toolbar-remove {
     background-image: url("images/toolbar-close.png"); }
+  div#toolbar > div#toolbar-removedata {
+    background-image: url("images/toolbar-trash.png"); }
   div#toolbar > div#toolbar-start {
     background-image: url("images/toolbar-start.png"); }
   div#toolbar > div#toolbar-pause {
Binary files transmission-2.84.orig/web/style/transmission/images/toolbar-trash.png and transmission-2.84/web/style/transmission/images/toolbar-trash.png differ
diff -urN transmission-2.84.orig/web/style/transmission/mobile.css transmission-2.84/web/style/transmission/mobile.css
--- transmission-2.84.orig/web/style/transmission/mobile.css	2014-07-01 21:10:53.310913397 +0400
+++ transmission-2.84/web/style/transmission/mobile.css	2014-09-04 22:51:11.000000000 +0400
@@ -82,6 +82,8 @@
     background-image: url("images/toolbar-folder.png"); }
   div#toolbar > div#toolbar-remove {
     background-image: url("images/toolbar-close.png"); }
+  div#toolbar > div#toolbar-removedata {
+    background-image: url("images/toolbar-trash.png"); }
   div#toolbar > div#toolbar-start {
     background-image: url("images/toolbar-start.png"); }
   div#toolbar > div#toolbar-pause {

Attachments (1)

toolbar-trash.png (1.9 KB) - added by dimonb 7 years ago.
button image

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by dimonb

button image

comment:1 Changed 7 years ago by Robby

  • Keywords patch added

comment:2 Changed 6 years ago by mike.dld

  • Component changed from Transmission to Web Client

comment:3 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5006.

Note: See TracTickets for help on using tickets.