Opened 7 years ago

Closed 7 years ago

#5790 closed Bug (worksforme)

Qt only: transmission crashes when adding new file to an already finished torrent

Reported by: jiehong Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Major Keywords:
Cc:

Description

Context On Archlinux 64, transmission Qt crashes when the following conditions are met:

  • a torrent with more than 1 file was added, but only 1 file was ticked to download;
  • the file has been downloaded, and the torrent is only seeding;

Steps

  1. right click on the torrent;
  2. select "Properties";
  3. go to the "Files" tab;
  4. tick the "download" case for another file

What happens? Transmission Qt exits right away.

Notes This crash does not occur if the torrent isn't finished. This works well with the GTK+ version.

Change History (2)

comment:1 Changed 7 years ago by mike.dld

Unable to reproduce. Any other information you could provide? GDB backtrace? Any other kind of crash report? Particular torrent causing troubles (if it's legit and publicly available)?

comment:2 Changed 7 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.