Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5814 closed Enhancement (wontfix)

Minor enhancement to scrollbar covering Reveal in Finder icon, & a feature request.

Reported by: TransmissionFan Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.84
Severity: Normal Keywords:
Cc:

Description

First off, I love your software. Yippie!

I have two feature requests that I believe would make your software even more amazing.

Whenever I attempt to click on the reveal in finder icon in the torrent list immediately(within 3 sec.) after having scrolled, it brings up the scrollbar animation that shows my progress with the scrolling, and it covers up the icon for 3 seconds. So, I find myself rolling my eyes about that one often because I have to move the mouse back over and wait for it to disappear, or click too soon and jump to another spot in the list. Maybe provide more spacing so that the icon isn't underneath the scrollbar. I could wait the 3 seconds every time, but time is money, and I'm impatient.

Also, it bothers me when I see a red indicator bubble displaying that I have three torrents that have finished, but I have no clue which ones. In a longer list, where sometimes it takes months to synchronously connect to a peer on an obscure file that isn't seeded often, the newly finished downloads could be anywhere. I know something finally got downloaded. I just never know what exactly. Frustrating. Maybe you could find an innovative way to highlight those newly finished downloads.

Thank you for hearing my ideas.

Change History (5)

comment:1 Changed 7 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for the feedback.

For the first issue, there have been tweaks to make this better, although there's no perfect solution with wasting space vs. overlap. What's in trunk right now is a fair compromise.

You can sort by Activity or Progress for the second issue. There's not a non-bloats way to convey this information unfortunately.

comment:2 Changed 7 years ago by collegeitdept

I believe what people are asking for is the following that I've been asking for YEARS:

  • Highlight a newly finished file in the table grid/list. Highlight the background in light orange (maybe pulsate).

comment:3 Changed 7 years ago by collegeitdept

"Won't fix. Why make things easier for the user"

comment:4 Changed 7 years ago by bigtex

Man, that scrollbar issue has been driving me crazy for ever. I just came here to file a bug on it, but I guess it won't be fixed.

I just checked the latest nightly build and the issue is still there. Even worse, the magnifying glass button highlights through the scrollbar when I mouse over it, so it really looks like I can click on it. But if I do, it moves the scrollbar, often jumping to a different place in the list than the torrent I was trying to reveal. There's just a tiny sliver of the button that can be pressed, otherwise I have to move the mouse out of the way and wait for the scrollbar to fade out.

comment:5 Changed 7 years ago by seryibaran

Scrollbar issue. It happens all the time for me. I switch to Transmission, scroll to a torrent, click the button to reveal torrent, but the scrollbar get's in the way.

I suggest making horizontal padding of a torrent row in the table a few pixels wider and increase pause/reveal buttons clickable area.

Current vertical padding looks right, but horizontal padding is too tight. The "Reveal button" is not vertically aligned with anything in the window anyway and could be moved a bit to the left. Here's what it would look like:

https://dl.dropboxusercontent.com/u/73036315/horpadding.png

The red line shows scroll bar width. The first item in the torrent list is my suggestion with horizontal padding increased by 4px. The second item has current padding.

Note: See TracTickets for help on using tickets.